This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 209915 - nautilus-cd-burner 2.14.3-1.fc5 does not use gnome-mount (miscompiled?)
nautilus-cd-burner 2.14.3-1.fc5 does not use gnome-mount (miscompiled?)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-07 22:46 EDT by Philippe Troin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: nautilus-cd-burner-2.14.3-2.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 21:46:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2006-10-07 22:46:39 EDT
Description of problem:
nautilus-cd-burner does not work when copying a DVD.
  nautilus-cd-burner --source-device=/dev/scd0
reports an "unknown error"

Version-Release number of selected component (if applicable):
2.14.3-1.fc5.i386

How reproducible:
Always.

I've ran:
  strace -ff -o LOG /usr/bin/nautilus-cd-burner --source-device=/dev/scd0
The various LOG* files show that nautilus-cd-burner attempts to call umount()
directly.  It should be using gnome-mount, but for some reason does not.

If I recompile the package with rpmbuild --rebuild, I can see that gnome-mount
is called, as expected.

So, the package in the archive has not been compiled properly.  Maybe a missing
build dependency?

This is on i386.  I'll check to see if I can reproduce it on a x86_64 box.

Phil.
Comment 1 Philippe Troin 2006-10-09 05:33:39 EDT
Was able to reproduce on x86_64.  Therefore changed hardware to "All".
Recompiling fixed the problem too.
Comment 2 Alexander Larsson 2006-10-11 14:11:39 EDT
Weird. It buildrequires gnome-mount, and passes --enable-gnome-mount.
Comment 3 Alexander Larsson 2006-10-11 14:13:07 EDT
Oh, it needs gnome-mount-devel
Comment 4 Alexander Larsson 2006-10-11 14:19:17 EDT
This if fixed in rawhide/fc6 at least
Comment 5 Philippe Troin 2006-10-11 18:19:02 EDT
I know you guys are busy trying to get fc6 out of the door, but since this is a
straight recompile, any chance it gets pushed to fc5 updates?
Comment 6 Alexander Larsson 2006-10-12 12:09:16 EDT
I built this as nautilus-cd-burner-2.14.3-2.fc5 in updates-testing. Could you
verify the fix when it gets pushed.
Comment 7 Fedora Update System 2006-10-16 10:56:59 EDT
nautilus-cd-burner-2.14.3-2.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 8 Fedora Update System 2006-10-16 15:13:02 EDT
nautilus-cd-burner-2.14.3-2.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 9 Fedora Update System 2006-10-23 11:37:02 EDT
nautilus-cd-burner-2.14.3-2.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.