Bug 209928 - Rescue system unable to be booted via pxe
Summary: Rescue system unable to be booted via pxe
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-08 12:59 UTC by Andreas Thienemann
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 16:41:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (29.98 KB, text/plain)
2006-10-10 22:59 UTC, Andreas Thienemann
no flags Details

Description Andreas Thienemann 2006-10-08 12:59:03 UTC
The rescue system is unable to be booted via PXE at the moment.

The anaconda installer is looking for a minstg2.img, while the cd only contains
a stage2.img file.

Symlinking the stage2.img file to minstg2.img is a workaround and makes anaconda
happy.

The PXE configuration for pxelinux:

label rhel5.rescue
  kernel rescue_rhel5_i386/vmlinuz
  append initrd=rescue_rhel5_i386/initrd.img rescue
ks=http://foo/rescue/ks_rhel5_i386.cfg console=tty0 console=ttyS1,57600n8r serial

The kickstart file:

lang en_US
keyboard de-latin1-nodeadkeys
network --device eth0 --bootproto dhcp
url --url http://foo/rescue/rhel5/i386
timezone --utc Europe/Berlin

Comment 1 Jeremy Katz 2006-10-09 15:16:03 UTC
How much RAM does the machine have?

Comment 2 Andreas Thienemann 2006-10-09 15:52:42 UTC
>1GB

Comment 3 Chris Lumens 2006-10-10 14:10:21 UTC
After getting into the graphical installer, please switch over to tty2, grab
/tmp/anaconda.log, and attach it to this bug report.

Comment 4 Andreas Thienemann 2006-10-10 22:59:13 UTC
Created attachment 138206 [details]
anaconda.log

I attached the bootlog from the rescue boot, while the image was symlinked.

Comment 5 Chris Lumens 2006-10-11 17:36:16 UTC
It's fetching minstg2.img because you are using a serial console.  Serial
implies text install, which is one of the criteria for using minstg2.img instead
of stage2.img.  This combined with the url install method is why it's trying to
fetch from a remote system.  If you are trying to have it use the CD for the
source of the stage2 image, either use the cdrom install method or just don't
use a kickstart file for this purpose.

Does this help explain the behavior you are seeing?  I'm not sure if it
qualifies as a bug or not.

Comment 6 Andreas Thienemann 2006-10-11 18:47:24 UTC
(In reply to comment #5)
> It's fetching minstg2.img because you are using a serial console.  Serial
> implies text install, which is one of the criteria for using minstg2.img instead
> of stage2.img.
Mhm. Yeah. That makes sense.

> This combined with the url install method is why it's trying to
> fetch from a remote system.  If you are trying to have it use the CD for the
> source of the stage2 image, either use the cdrom install method or just don't
> use a kickstart file for this purpose.
Nah, I'm perfectly alright with it pulling the data from the remote server.
That's exactly what I'm trying to do, booting a remote machine in the
data-center into the rescue mode.

> Does this help explain the behavior you are seeing?  I'm not sure if it
> qualifies as a bug or not.
Well, trying the network URL given in the kickstart file is definitly no bug.
That is what I'm expecting.

The problem is that anaconda (when booting via serial) tries accessing
minstg2.img which is not available on the rescue-CD at the moment.
One can only get the rescue-CD to work after symlinking the stage2.img file to
the (non-existing) minstg2.img file.

Comment 7 RHEL Product and Program Management 2007-09-14 16:41:59 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 


Note You need to log in before you can comment on or make changes to this bug.