This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 209980 - Yum stops with a list dump when disk space on the target partition is not enough
Yum stops with a list dump when disk space on the target partition is not enough
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 04:26 EDT by Mayank Jain
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version: 3.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-03 16:26:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mayank Jain 2006-10-09 04:26:38 EDT
Description of problem:
Yum fails with a dump when disk space on the target partition is not enough

---START---
(439/439): bitstream-vera 100% |=========================| 343 kB    00:00     
Running Transaction Test
warning: crash-4.0-3.3: Header V3 DSA signature: NOKEY, key ID 897da07a
Finished Transaction Test
Transaction Test Succeeded
Running Transaction


[('installing package firefox-devel-1.5.0.7-6.fc6 needs 14MB on the /
filesystem', (9, '/', 14454784L)), ('installing package epiphany-2.16.0-2.fc6
needs 20MB on the / filesystem', (9, '/', 20848640L)), ('installing package
yelp-2.16.0-3.fc6 needs 22MB on the / filesystem', (9, '/', 22331392L)),
('installing package xorg-x11-drv-ati-6.6.2-4.fc6 needs 22MB on the /
filesystem', (9, '/', 22319104L)), ('installing package xorg-x11-drv-sis-0.9.1-7
needs 22MB on the / filesystem', (9, '/', 22306816L)), ('installing package
file-roller-2.16.0-2.fc6 needs 24MB on the / filesystem', (9, '/', 24236032L)),
('installing package evince-0.6.0-3.fc6 needs 25MB on the / filesystem', (9,
'/', 25874432L)), ('installing package ekiga-2.0.2-7 needs 31MB on the /
filesystem', (9, '/', 32022528L)), ('installing package jessie-1.0.1-7 needs
31MB on the / filesystem', (9, '/', 32092160L)), ('installing package
jakarta-commons-codec-1.3-7jpp.2 needs 31MB on the / filesystem', (9, '/',
32112640L)), ('installing package gnome-system-monitor-2.16.0-1.fc6 needs 33MB
on the / filesystem', (9, '/', 33583104L)), ('installing package
desktop-printing-0.19-16.fc6 needs 33MB on the / filesystem', (9, '/',
33775616L)), ('installing package im-chooser-0.3.3-2.fc6 needs 33MB on the /
filesystem', (9, '/', 34160640L)), ('installing package
gnome-power-manager-2.16.0-3.fc6 needs 35MB on the / filesystem', (9, '/',
36093952L)), ('installing package glade2-2.12.1-5.fc6 needs 39MB on the /
filesystem', (9, '/', 40263680L)), ('installing package
gnome-terminal-2.16.0-2.fc6 needs 44MB on the / filesystem', (9, '/',
45924352L)), ('installing package gnome-keyring-manager-2.16.0-2.fc6 needs 45MB
on the / filesystem', (9, '/', 46764032L)), ('installing package gok-1.2.0-1.fc6
needs 48MB on the / filesystem', (9, '/', 49401856L)), ('installing package
gconf-editor-2.16.0-2.fc6 needs 48MB on the / filesystem', (9, '/', 50216960L)),
('installing package gcalctool-5.8.24-2.fc6 needs 50MB on the / filesystem', (9,
'/', 52088832L)), ('installing package eog-2.16.0.1-2.fc6 needs 52MB on the /
filesystem', (9, '/', 53587968L)), ('installing package
sane-backends-libs-1.0.18-2.fc6 needs 53MB on the / filesystem', (9, '/',
55128064L)), ('installing package sane-backends-1.0.18-2.fc6 needs 55MB on the /
filesystem', (9, '/', 56811520L))]
[root@majain ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda1              39G   36G  1.1G  98% /
---END---

Version-Release number of selected component (if applicable):
yum-2.9.6-1

How reproducible:
Everytime

  
Actual results:
yum stops with a list dump

Expected results:
Yum should exit with a user friendly message

Additional info:
None
Comment 1 Seth Vidal 2007-08-03 16:26:53 EDT
I think we got this all cleaned up in 3.0.X and 3.2.X closing this now.

thank you

Note You need to log in before you can comment on or make changes to this bug.