This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 209985 - RFE: new version 7.0 of dvd+rw-tools available
RFE: new version 7.0 of dvd+rw-tools available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dvd+rw-tools (Show other bugs)
rawhide
All All
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 05:57 EDT by Moritz Barsnick
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: dvd+rw-tools-7.0-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-27 08:24:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
updated SPEC file for 7.0 with several enhancements (diff vs. previous SPEC file for 6.1-4.1) (1.83 KB, patch)
2006-10-09 05:57 EDT, Moritz Barsnick
no flags Details | Diff
current index.html from upstream (63.78 KB, text/html)
2006-10-09 05:59 EDT, Moritz Barsnick
no flags Details
updated manpath patch for 7.0 (1.30 KB, patch)
2006-10-09 06:01 EDT, Moritz Barsnick
no flags Details | Diff

  None (edit)
Description Moritz Barsnick 2006-10-09 05:57:05 EDT
Description of problem:
A new version 7.0 of dvd+rw-tools is available. The current SPEC file also has 
some "peculiarities". Please update or test if possible. (Also, be the first 
distribution to support Blu-Ray. ;->)

Version-Release number of selected component (if applicable):
6.1-4.1

How reproducible:
always

Steps to Reproduce:

  
Actual results:


Expected results:


Additional info:
I know 6.1-2 has never left Updates/testing for FC5, but since 6.1-4.1 is in 
Rawhide/development, please perhaps consider version 7.0.

I'm attaching some suggested enhancements/fixes to the SPEC file as well:
- use new index.html (previous one was from Aug. 2004)
- don't explicitly install the doc, just use the %doc directive
- LICENSE needs to be packaged (AFAIK)
- parallel build is possible

Upstream changelog (grabbed from the included SPEC file):
- Blu-ray Disc support [upon release tested with Panasonic SW-5582]
- Mac OS X 10>=2 support [upon release tested on 10.4 only]
- Linux: copy <linux/raw.h> definitions directly into application
  code in order to secure backward compatibility
- Linux: overcome 16MB O_DIRECT limitaton for NFS client
- limit ring buffer size to 1/4 of RAM
- copy volume descriptors if -C was specified with -M /dev/dvd=image
  [by request from K3b]
- -use-the-force-luke=spare[:none|min] to control blank BD pre-format
  [for finer control use dvd+rw-format]
- some units, e.g. Lite-on SOHW-1693S, seem to fire off OPC already
  upon Layer Break command, therefore longer timeout is required
- Linux: deploy BLKFLSBUF to avoid media reloads when possible
- add unit buffer utilization indicator [by request from K3b]
Comment 1 Moritz Barsnick 2006-10-09 05:57:05 EDT
Created attachment 138030 [details]
updated SPEC file for 7.0 with several enhancements (diff vs. previous SPEC file for 6.1-4.1)
Comment 2 Moritz Barsnick 2006-10-09 05:59:52 EDT
Created attachment 138031 [details]
current index.html from upstream
Comment 3 Moritz Barsnick 2006-10-09 06:01:07 EDT
Created attachment 138032 [details]
updated manpath patch for 7.0

Sorry for the fuzzy filename (in the SPEC as well). :-/

Note You need to log in before you can comment on or make changes to this bug.