Bug 210040 - Yum updates failing in fc6test3
Yum updates failing in fc6test3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 13:41 EDT by Jonathan S. Shapiro
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-09 15:58:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan S. Shapiro 2006-10-09 13:41:44 EDT
This may be trivially closable, but if I have the diagnosis right it may
(regrettably) be a reason to delay FC6 release. Or possibly I'm just not on the
appropriate mailing lists to have gotten the notice about this.

On my machine, *many* packages are not listed by yum list, and yum-3.0-3 was not
been pulled by the update process (I noticed this because attempts to update
fedora-kmod to 3.0-3 using the previous version of yum failed because the older
version of yum was unable to locate yum-3.0-3 in the repository). Example: try
"yum list|grep tetex" and you will see nothing (this is with fc6test3, yum
preceding 3.0-3. Sorry -- didn't think to jot down the yum version before
upgrading it by hand).

The faulty version of yum also appears to infinite loop when it is pointed
directly at the development repository, and also on some (but curiously not all)
mirrors. It seems possible that some of the mirrors (e.g. ibiblio) are not updating.

After hand-updating YUM to the version currently in the development/ tree (which
is 3.0-3), using yum update suddenly lists a vast number of packages to be updated.

So: the proximate bug appears to be fixed in yum-3.0-3. Hopefully, this is just
something where I didn't see the email, and everybody else knows that they
should hand update, and all is well. My concern is that if many people running
FC6test3 are running the faulty version of yum, then it is likely that many bug
fixes are not propagating and therefore may not be getting tested. This is why I
rated this "urgent".

Best guess on how to reproduce (which I have not tried):

Do a clean install of FC6test3 and run yum update. Check if yum >= 3.0-3 ends up
on your machine.

Note that my original install on this particular machine was from the 5.92 ISOs,
*not* from the ISOs in the development/ tree.  I have no way to know if the
issue is resolved in the later ISO images.
Comment 1 Jeremy Katz 2006-10-09 15:58:16 EDT
There was a bug with yum where it was messing up repo urls -- if you install the
newer yum packages, this will be resolved

Note You need to log in before you can comment on or make changes to this bug.