Bug 210063 - possible circular locking dependency detected (cp and 2.6.18-1.2189.fc5)
possible circular locking dependency detected (cp and 2.6.18-1.2189.fc5)
Status: CLOSED DUPLICATE of bug 210062
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 15:57 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-12 11:00:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-10-09 15:57:32 EDT
Oct  4 15:03:33 cynosure kernel: [ INFO: possible circular locking dependency
detected ]
Oct  4 15:03:33 cynosure kernel: 2.6.18-1.2189.fc5 #1
Oct  4 15:03:33 cynosure kernel:
-------------------------------------------------------
Oct  4 15:03:33 cynosure kernel: cp/16381 is trying to acquire lock:
Oct  4 15:03:33 cynosure kernel:  (sk_lock-AF_INET){--..}, at: [<c05c7d12>]
tcp_sendmsg+0
x14/0x9a7
Oct  4 15:03:33 cynosure kernel:
Oct  4 15:03:33 cynosure kernel: but task is already holding lock:
Oct  4 15:03:33 cynosure kernel:  (&inode->i_alloc_sem){--..}, at: [<c047b55a>]
notify_ch
ange+0xe5/0x2c3
Oct  4 15:03:33 cynosure kernel:
Oct  4 15:03:33 cynosure kernel: which lock already depends on the new lock.
Oct  4 15:03:33 cynosure kernel:
Oct  4 15:03:33 cynosure kernel:
Oct  4 15:03:33 cynosure kernel: the existing dependency chain (in reverse
order) is:
Oct  4 15:03:33 cynosure kernel:
Oct  4 15:03:33 cynosure kernel: -> #3 (&inode->i_alloc_sem){--..}:
Oct  4 15:03:33 cynosure kernel:        [<c0431870>] lock_acquire+0x4b/0x6b
Oct  4 15:03:33 cynosure kernel:        [<c042e89c>] down_write+0x2d/0x47
Oct  4 15:03:33 cynosure kernel:        [<c047b55a>] notify_change+0xe5/0x2c3
Oct  4 15:03:33 cynosure kernel:        [<c0463188>] do_truncate+0x53/0x6c
Oct  4 15:03:33 cynosure kernel:        [<c0470fe3>] may_open+0x1b6/0x204
Oct  4 15:03:33 cynosure kernel:        [<c0473111>] open_namei+0x286/0x638
Oct  4 15:03:33 cynosure kernel:        [<c0462f15>] do_filp_open+0x1f/0x35
Oct  4 15:03:33 cynosure kernel:        [<c0462f6b>] do_sys_open+0x40/0xb5
Oct  4 15:03:33 cynosure kernel:        [<c046300c>] sys_open+0x16/0x18
Oct  4 15:03:33 cynosure kernel:        [<c0402dc7>] syscall_call+0x7/0xb
Oct  4 15:03:33 cynosure kernel:
Oct  4 15:03:33 cynosure kernel: -> #2 (&sysfs_inode_imutex_key){--..}:
Oct  4 15:03:33 cynosure kernel:        [<c0431870>] lock_acquire+0x4b/0x6b
Oct  4 15:03:33 cynosure kernel:        [<c05f9c82>]
__mutex_lock_slowpath+0xb3/0x1fc
Oct  4 15:03:33 cynosure kernel:        [<c05f9dec>] mutex_lock+0x21/0x24
Oct  4 15:03:33 cynosure kernel:        [<c049b244>] create_dir+0x20/0x195
Oct  4 15:03:33 cynosure kernel:        [<c049b8d8>] sysfs_create_dir+0x48/0x63
Oct  4 15:03:33 cynosure kernel:        [<c04d7585>] kobject_add+0xc7/0x171
Oct  4 15:03:33 cynosure kernel:        [<c0542e4c>] class_device_add+0x99/0x3c4
Oct  4 15:03:33 cynosure kernel:        [<c05af08c>] netdev_register_sysfs+0x76/0x7b
Oct  4 15:03:33 cynosure kernel:        [<c05a5364>] register_netdevice+0x229/0x2e1
Oct  4 15:03:33 cynosure kernel:        [<c05a6504>] register_netdev+0x5c/0x69
Oct  4 15:03:33 cynosure kernel:        [<c079cea6>] loopback_init+0x3e/0x41
Oct  4 15:03:33 cynosure kernel:        [<c079cdda>] net_olddevs_init+0xa/0x98
Oct  4 15:03:33 cynosure kernel:        [<c04002ed>] init+0x91/0x20a
Oct  4 15:03:33 cynosure kernel:        [<c0401005>] kernel_thread_helper+0x5/0xb
Oct  4 15:03:33 cynosure kernel:
Oct  4 15:03:33 cynosure kernel: -> #1 (rtnl_mutex){--..}:
Oct  4 15:03:33 cynosure kernel:        [<c0431870>] lock_acquire+0x4b/0x6b
Oct  4 15:03:33 cynosure kernel:        [<c05f9c82>]
__mutex_lock_slowpath+0xb3/0x1fc
Oct  4 15:03:33 cynosure kernel:        [<c05f9dec>] mutex_lock+0x21/0x24
Oct  4 15:03:33 cynosure kernel:        [<c05acec2>] rtnl_lock+0xd/0xf
Oct  4 15:03:33 cynosure kernel:        [<c05e15f6>] ip_mc_leave_group+0x18/0xaa
Oct  4 15:03:33 cynosure kernel:        [<c05c42a9>] ip_setsockopt+0x664/0x9ab
Oct  4 15:03:33 cynosure kernel:        [<c05d94e6>] udp_setsockopt+0x1f/0x9c
Oct  4 15:03:33 cynosure kernel:        [<c059e52e>]
sock_common_setsockopt+0x13/0x18
Oct  4 15:03:33 cynosure kernel:        [<c059d2bf>] sys_setsockopt+0x6f/0x8d
Oct  4 15:03:33 cynosure kernel:        [<c059e1d0>] sys_socketcall+0x148/0x186
Oct  4 15:03:33 cynosure kernel:        [<c0402dc7>] syscall_call+0x7/0xb
Oct  4 15:03:33 cynosure kernel:
Oct  4 15:03:33 cynosure kernel: -> #0 (sk_lock-AF_INET){--..}:
Oct  4 15:03:33 cynosure kernel:        [<c0431870>] lock_acquire+0x4b/0x6b
Oct  4 15:03:33 cynosure kernel:        [<c059eb9a>] lock_sock+0xaf/0xbf
Oct  4 15:03:33 cynosure kernel:        [<c05c7d12>] tcp_sendmsg+0x14/0x9a7
Oct  4 15:03:33 cynosure kernel:        [<c05df002>] inet_sendmsg+0x3b/0x48
Oct  4 15:03:33 cynosure kernel:        [<c059c8fa>] sock_sendmsg+0xe8/0x103
Oct  4 15:03:33 cynosure kernel:        [<c059e236>] kernel_sendmsg+0x28/0x37
Oct  4 15:03:33 cynosure kernel:        [<f8b76ffe>]
xs_tcp_send_request+0xea/0x2db [sunr
pc]
Oct  4 15:03:33 cynosure kernel:        [<f8b7625c>] xprt_transmit+0xb8/0x18c
[sunrpc]
Oct  4 15:03:33 cynosure kernel:        [<f8b743ca>] call_transmit+0x1ad/0x1d9
[sunrpc]
Oct  4 15:03:33 cynosure kernel:        [<f8b79070>] __rpc_execute+0x6e/0x182
[sunrpc]
Oct  4 15:03:33 cynosure kernel:        [<f8b791a0>] rpc_execute+0x12/0x14 [sunrpc]
Oct  4 15:03:33 cynosure kernel:        [<f8b74528>] rpc_call_sync+0x6e/0x97
[sunrpc]
Oct  4 15:03:33 cynosure kernel:        [<f8f8ebf9>] nfs3_rpc_wrapper+0x24/0x62
[nfs]
Oct  4 15:03:33 cynosure kernel:        [<f8f8ee6a>] nfs3_proc_setattr+0x7f/0xaf
[nfs]
Oct  4 15:03:33 cynosure kernel:        [<f8f8756b>] nfs_setattr+0xe9/0x109 [nfs]
Oct  4 15:03:33 cynosure kernel:        [<c047b5a2>] notify_change+0x12d/0x2c3
Oct  4 15:03:33 cynosure kernel:        [<c0463188>] do_truncate+0x53/0x6c
Oct  4 15:03:33 cynosure kernel:        [<c0470fe3>] may_open+0x1b6/0x204
Oct  4 15:03:33 cynosure kernel:        [<c0473111>] open_namei+0x286/0x638
Oct  4 15:03:33 cynosure kernel:        [<c0462f15>] do_filp_open+0x1f/0x35
Oct  4 15:03:33 cynosure kernel:        [<c0462f6b>] do_sys_open+0x40/0xb5
Oct  4 15:03:33 cynosure kernel:        [<c046300c>] sys_open+0x16/0x18
Oct  4 15:03:33 cynosure kernel:        [<c0402dc7>] syscall_call+0x7/0xb
Oct  4 15:03:33 cynosure kernel:
Oct  4 15:03:33 cynosure kernel: other info that might help us debug this:
Oct  4 15:03:33 cynosure kernel:
Oct  4 15:03:33 cynosure kernel: 2 locks held by cp/16381:
Oct  4 15:03:33 cynosure kernel:  #0:  (&inode->i_mutex){--..}, at: [<c05f9dec>]
mutex_lo
ck+0x21/0x24
Oct  4 15:03:33 cynosure kernel:  #1:  (&inode->i_alloc_sem){--..}, at:
[<c047b55a>] noti
fy_change+0xe5/0x2c3
Oct  4 15:03:33 cynosure kernel:
Oct  4 15:03:33 cynosure kernel: stack backtrace:
Oct  4 15:03:33 cynosure kernel:  [<c0403f8d>] show_trace_log_lvl+0x58/0x16a
Oct  4 15:03:33 cynosure kernel:  [<c0404565>] show_trace+0xd/0x10
Oct  4 15:03:33 cynosure kernel:  [<c0404602>] dump_stack+0x19/0x1b
Oct  4 15:03:33 cynosure kernel:  [<c043096e>] print_circular_bug_tail+0x59/0x64
Oct  4 15:03:33 cynosure kernel:  [<c043115b>] __lock_acquire+0x7e2/0x986
Oct  4 15:03:33 cynosure kernel:  [<c0431870>] lock_acquire+0x4b/0x6b
Oct  4 15:03:33 cynosure kernel:  [<c059eb9a>] lock_sock+0xaf/0xbf
Oct  4 15:03:33 cynosure kernel:  [<c05c7d12>] tcp_sendmsg+0x14/0x9a7
Oct  4 15:03:33 cynosure kernel:  [<c05df002>] inet_sendmsg+0x3b/0x48
Oct  4 15:03:33 cynosure kernel:  [<c059c8fa>] sock_sendmsg+0xe8/0x103
Oct  4 15:03:33 cynosure kernel:  [<c059e236>] kernel_sendmsg+0x28/0x37
Oct  4 15:03:33 cynosure kernel:  [<f8b76ffe>] xs_tcp_send_request+0xea/0x2db
[sunrpc]
Oct  4 15:03:33 cynosure kernel:  [<f8b7625c>] xprt_transmit+0xb8/0x18c [sunrpc]
Oct  4 15:03:33 cynosure kernel:  [<f8b743ca>] call_transmit+0x1ad/0x1d9 [sunrpc]
Oct  4 15:03:33 cynosure kernel:  [<f8b79070>] __rpc_execute+0x6e/0x182 [sunrpc]
Oct  4 15:03:33 cynosure kernel:  [<f8b791a0>] rpc_execute+0x12/0x14 [sunrpc]
Oct  4 15:03:33 cynosure kernel:  [<f8b74528>] rpc_call_sync+0x6e/0x97 [sunrpc]
Oct  4 15:03:33 cynosure kernel:  [<f8f8ebf9>] nfs3_rpc_wrapper+0x24/0x62 [nfs]
Oct  4 15:03:33 cynosure kernel:  [<f8f8ee6a>] nfs3_proc_setattr+0x7f/0xaf [nfs]
Oct  4 15:03:33 cynosure kernel:  [<f8f8756b>] nfs_setattr+0xe9/0x109 [nfs]
Oct  4 15:03:33 cynosure kernel:  [<c047b5a2>] notify_change+0x12d/0x2c3
Oct  4 15:03:33 cynosure kernel:  [<c0463188>] do_truncate+0x53/0x6c
Oct  4 15:03:33 cynosure kernel:  [<c0470fe3>] may_open+0x1b6/0x204
Oct  4 15:03:33 cynosure kernel:  [<c0473111>] open_namei+0x286/0x638
Oct  4 15:03:33 cynosure kernel:  [<c0462f15>] do_filp_open+0x1f/0x35
Oct  4 15:03:33 cynosure kernel:  [<c0462f6b>] do_sys_open+0x40/0xb5
Oct  4 15:03:33 cynosure kernel:  [<c046300c>] sys_open+0x16/0x18
Oct  4 15:03:33 cynosure kernel:  [<c0402dc7>] syscall_call+0x7/0xb
Oct  4 15:03:33 cynosure kernel: DWARF2 unwinder stuck at syscall_call+0x7/0xb
Oct  4 15:03:33 cynosure kernel: Leftover inexact backtrace:
Oct  4 15:03:33 cynosure kernel:  [<c0404565>] show_trace+0xd/0x10
Oct  4 15:03:33 cynosure kernel:  [<c0404602>] dump_stack+0x19/0x1b
Oct  4 15:03:33 cynosure kernel:  [<c043096e>] print_circular_bug_tail+0x59/0x64
Oct  4 15:03:33 cynosure kernel:  [<c043115b>] __lock_acquire+0x7e2/0x986
Oct  4 15:03:33 cynosure kernel:  [<c0431870>] lock_acquire+0x4b/0x6b
Oct  4 15:03:33 cynosure kernel:  [<c059eb9a>] lock_sock+0xaf/0xbf
Oct  4 15:03:33 cynosure kernel:  [<c05c7d12>] tcp_sendmsg+0x14/0x9a7
Oct  4 15:03:33 cynosure kernel:  [<c05df002>] inet_sendmsg+0x3b/0x48
Oct  4 15:03:33 cynosure kernel:  [<c059c8fa>] sock_sendmsg+0xe8/0x103
Oct  4 15:03:33 cynosure kernel:  [<c059e236>] kernel_sendmsg+0x28/0x37
Oct  4 15:03:33 cynosure kernel:  [<f8b76ffe>] xs_tcp_send_request+0xea/0x2db
[sunrpc]
Oct  4 15:03:33 cynosure kernel:  [<f8b7625c>] xprt_transmit+0xb8/0x18c [sunrpc]
Oct  4 15:03:33 cynosure kernel:  [<f8b743ca>] call_transmit+0x1ad/0x1d9 [sunrpc]
Oct  4 15:03:33 cynosure kernel:  [<f8b79070>] __rpc_execute+0x6e/0x182 [sunrpc]
Oct  4 15:03:33 cynosure kernel:  [<f8b791a0>] rpc_execute+0x12/0x14 [sunrpc]
Oct  4 15:03:33 cynosure kernel:  [<f8b74528>] rpc_call_sync+0x6e/0x97 [sunrpc]
Oct  4 15:03:33 cynosure kernel:  [<f8f8ebf9>] nfs3_rpc_wrapper+0x24/0x62 [nfs]
Oct  4 15:03:33 cynosure kernel:  [<f8f8ee6a>] nfs3_proc_setattr+0x7f/0xaf [nfs]
Oct  4 15:03:33 cynosure kernel:  [<f8f8756b>] nfs_setattr+0xe9/0x109 [nfs]
Oct  4 15:03:33 cynosure kernel:  [<c047b5a2>] notify_change+0x12d/0x2c3
Oct  4 15:03:33 cynosure kernel:  [<c0463188>] do_truncate+0x53/0x6c
Oct  4 15:03:33 cynosure kernel:  [<c0470fe3>] may_open+0x1b6/0x204
Oct  4 15:03:33 cynosure kernel:  [<c0473111>] open_namei+0x286/0x638
Oct  4 15:03:33 cynosure kernel:  [<c0462f15>] do_filp_open+0x1f/0x35
Oct  4 15:03:33 cynosure kernel:  [<c0462f6b>] do_sys_open+0x40/0xb5
Oct  4 15:03:33 cynosure kernel:  [<c046300c>] sys_open+0x16/0x18
Oct  4 15:03:33 cynosure kernel:  [<c0402dc7>] syscall_call+0x7/0xb
Comment 1 Jeffrey Moyer 2006-10-12 11:00:20 EDT
I believe these two issues are the same.

*** This bug has been marked as a duplicate of 210062 ***

Note You need to log in before you can comment on or make changes to this bug.