Bug 210067 - When X starts, PC appears to freeze
When X starts, PC appears to freeze
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 16:27 EDT by Douglas Furlong
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 11:40:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file when using the radeon driver and system freezes. (35.79 KB, text/plain)
2006-10-09 16:27 EDT, Douglas Furlong
no flags Details
Configuration file when system freezes. (1.12 KB, text/plain)
2006-10-09 16:30 EDT, Douglas Furlong
no flags Details
Log file when using the vesa driver (system working in 1024*768) (62.75 KB, text/plain)
2006-10-09 16:32 EDT, Douglas Furlong
no flags Details
startx 2> output when starting from a terminal (run level3) (1.91 KB, text/plain)
2006-10-09 16:34 EDT, Douglas Furlong
no flags Details

  None (edit)
Description Douglas Furlong 2006-10-09 16:27:11 EDT
Description of problem:
After a recent update, when attempting to start X, in a user session (either via
GDM or "startx" after booting to run level 3) the system appears to freeze.

CTRL + ALT + DEL has no affect, numblock/capslock has no effect.

I believe the backlight of the screen is still on.

If leaving the xorg.conf file unedited with radeon as the driver, the RHGB boot
screen starts normally (1280*800) but when xorg reloads for GDM the system freezes.

Editin xorg and using the VESA driver, the system starts (in 1024*768).

Please let me know if any other description is required.

Version-Release number of selected component (if applicable):
rpm -qi xorg-x11-drv-ati
Name        : xorg-x11-drv-ati             Relocations: (not relocatable)
Version     : 6.6.2                             Vendor: Red Hat, Inc.
Release     : 4.fc6                         Build Date: Mon 02 Oct 2006 04:33:56
PM BST

How reproducible:
every damn time

Steps to Reproduce:
1. Use "radeon" as the driver, and startx within a user session.
2.
3.
  
Actual results:
System freezes

Expected results:
system not to freeze

Additional info:
lspci
00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI
Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge
(rev 03)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M9+ 5C61 [Radeon
Mobility 9200 (AGP)] (rev 01)
02:04.0 CardBus bridge: Texas Instruments PCI7420 CardBus Controller
02:04.2 FireWire (IEEE 1394): Texas Instruments PCI7x20 1394a-2000 OHCI Two-Port
PHY/Link-Layer Controller
02:04.3 Mass storage controller: Texas Instruments PCI7420/7620 Combo CardBus,
1394a-2000 OHCI and SD/MS-Pro Controller
02:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE (MOB) Ethernet
Controller (rev 83)
02:0b.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network
Connection (rev 05)
Comment 1 Douglas Furlong 2006-10-09 16:27:11 EDT
Created attachment 138072 [details]
Log file when using the radeon driver and system freezes.
Comment 2 Douglas Furlong 2006-10-09 16:30:25 EDT
Created attachment 138073 [details]
Configuration file when system freezes.
Comment 3 Douglas Furlong 2006-10-09 16:32:11 EDT
Created attachment 138074 [details]
Log file when using the vesa driver (system working in 1024*768)
Comment 4 Douglas Furlong 2006-10-09 16:34:45 EDT
Created attachment 138075 [details]
startx 2> output when starting from a terminal (run level3)
Comment 5 Kristian Høgsberg 2006-10-13 15:47:47 EDT
Maybe dupe of 208711.
Comment 6 Douglas Furlong 2006-10-14 16:38:29 EDT
I don't think it is a dupe of that bug, I had reviewed it before posting mine.

My system locks hard straight away, and the screen does not appear to go in to
power saving mode.

I've now used Option NoAccel "1", and I can get X running with the radeon
driver, which to me suggests it is some thing to do with the acceleratoin code :)

At least now I have native resolution (but speed sucks).

If I can narrow it down some more, I will update the bug.

If any one has any hints or thoughts, feel free to share :))
Comment 7 Douglas Furlong 2007-03-13 11:40:10 EDT
I no longer have this laptop, and as such I can no longer provide any useful bug
data for this, so it may as well be resolved.

Note You need to log in before you can comment on or make changes to this bug.