Bug 210111 - No sound under KDE - missing ACLs
No sound under KDE - missing ACLs
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
8
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 22:32 EDT by Th0ma7
Modified: 2013-03-05 22:47 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-30 05:55:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The actual ARTS error message (27.40 KB, image/png)
2006-10-10 09:21 EDT, Th0ma7
no flags Details

  None (edit)
Description Th0ma7 2006-10-09 22:32:27 EDT
Description of problem:
Each time I log in I'm getting a window error "ALSA fatal error ... "

Version-Release number of selected component (if applicable):
udev-095-13

How reproducible:
Every time

Expected results:
Sound working?

How to fix:
I've been able to fix the problem by modifying the uedv rules associated with
alsa.  I've edited the file /etc/udev/rules.d/90-alsa.rules and replaced theses
two lines:
SUBSYSTEM=="sound", KERNEL=="controlC*" RUN+="/sbin/salsa"
SUBSYSTEM=="sound", KERNEL=="pcm*"      RUN+="/sbin/salsa"
With thoses:
SUBSYSTEM=="sound", KERNEL=="controlC*", OWNER="root" GROUP="root", MODE="0666",
RUN+="/sbin/salsa"
SUBSYSTEM=="sound", KERNEL=="pcm*",      OWNER="root" GROUP="root", MODE="0666",
RUN+="/sbin/salsa"

Doing so allowed my user to read and write to both the controls (volumes, etc.)
and write sound to the device!

This might be a bit dirty?  but hey, it works!

- vin
Comment 1 Harald Hoyer 2006-10-10 04:12:07 EDT
$ rpm -qf /etc/udev/rules.d/90-alsa.rules
alsa-utils-1.0.12-1.rc2.fc6
Comment 2 Harald Hoyer 2006-10-10 04:29:43 EDT
though, the console permissions should be set by pam_console..

$ rpm -qf /etc/security/console.perms.d/50-default.perms
pam-0.99.5.0-8.fc6

<sound>=/dev/dsp* /dev/audio* /dev/midi* \
        /dev/mixer* /dev/sequencer* \
        /dev/sound/* /dev/beep \
        /dev/snd/* /dev/adsp*

so the console user gets the permissions to use /dev/snd/* which should also
include /dev/snd/pcm* and /dev/snd/controlC*


Comment 3 Martin Stransky 2006-10-10 04:33:23 EDT
(In reply to comment #2)
> though, the console permissions should be set by pam_console..
> 
> $ rpm -qf /etc/security/console.perms.d/50-default.perms
> pam-0.99.5.0-8.fc6
> 
> <sound>=/dev/dsp* /dev/audio* /dev/midi* \
>         /dev/mixer* /dev/sequencer* \
>         /dev/sound/* /dev/beep \
>         /dev/snd/* /dev/adsp*
> 
> so the console user gets the permissions to use /dev/snd/* which should also
> include /dev/snd/pcm* and /dev/snd/controlC*

You're exactly right.
Comment 4 Martin Stransky 2006-10-10 04:36:15 EDT
Could you please check this command? (on console, after log-in as a common user)

aplay /usr/share/sounds/phone.wav
Comment 5 Th0ma7 2006-10-10 09:20:30 EDT
Curiously enough, the sound worked yesterday night... Although this morning I
got back the same error with the sound server...?

Here is the output:
[megaloutre@th0ma7]~% aplay /usr/share/sounds/phone.wav
aplay: main:550: audio open error: No such file or directory
[megaloutre@th0ma7]~% ll /usr/share/sounds/phone.wav
-r--r--r-- 1 root root 455544 Jul 12 06:08 /usr/share/sounds/phone.wav
[megaloutre@th0ma7]~% which aplay
/usr/bin/aplay
[megaloutre@th0ma7]~% /usr/bin/aplay /usr/share/sounds/phone.wav
aplay: main:550: audio open error: No such file or directory

In console mode (runlvl 4):
[megaloutre@th0ma7]~% /usr/bin/aplay /usr/share/sounds/phone.wav
aplay: main:550: audio open error: No such file or directory

I've checked pam and it looks like I have two versions of it (might be i386 +
x86_64):
[megaloutre@th0ma7]~% rpm -qf /etc/security/console.perms.d/50-default.perms
pam-0.99.6.2-3.fc6
pam-0.99.6.2-3.fc6
[megaloutre@th0ma7]~% rpm -qf /etc/udev/rules.d/90-alsa.rules
alsa-utils-1.0.12-3.fc6

Note that this is a clean install of fc6t3 + updates.

Seems it ain't working properly yet.  I'll dig in for more info later on.

- vin
Comment 6 Th0ma7 2006-10-10 09:21:25 EDT
Created attachment 138133 [details]
The actual ARTS error message
Comment 7 Th0ma7 2006-10-10 09:32:22 EDT
Also, here are the actual permissions on the sound devices:
[megaloutre@th0ma7]~% ll /dev/snd/*
crw------- 1 megaloutre root 116, 5 Oct 10 09:23 /dev/snd/controlC0
crw------- 1 megaloutre root 116, 4 Oct 10 09:23 /dev/snd/pcmC0D0c
crw------- 1 megaloutre root 116, 3 Oct 10 09:23 /dev/snd/seq
crw------- 1 megaloutre root 116, 2 Oct 10 09:23 /dev/snd/timer

And here is the info on the device:
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237
AC97 Audio Controller (rev 60)
        Subsystem: ASUSTeK Computer Inc. A8V Deluxe motherboard (Realtek ALC850
codec)
        Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin C routed to IRQ 5
        Region 0: I/O ports at e800 [size=256]
        Capabilities: [c0] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

It is built-in on a ASUS A8V-Deluxe motherboard.

I also have attached a Logitech webcam...

Here is some parts of my dmesg which might be usefull (I think the pwc parts are
associated with the webcam?):
Linux video capture interface: v2.00
pwc: Unknown parameter `index'
input: PC Speaker as /class/input/input2
EDAC MC: Ver: 2.0.1 Oct  6 2006
EDAC MC0: Giving out device to k8_edac Athlon64/Opteron: DEV 0000:00:18.2
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 3 if 0 alt 1
proto 2 vid 0x03F0 pid 0x1204
usbcore: registered new driver usblp
drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
GSI 18 sharing vector 0xB9 and IRQ 18
ACPI: PCI Interrupt 0000:00:0a.0[A] -> GSI 17 (level, low) -> IRQ 185
skge 1.6 addr 0xf9a00000 irq 185 chip Yukon-Lite rev 9
skge eth0: addr 00:13:d4:11:03:a9
ieee1394: Initialized config rom entry `ip1394'
pwc: Unknown parameter `index'
pwc: Unknown parameter `index'
Comment 8 Th0ma7 2006-10-11 06:22:06 EDT
I tried to resolve the pwc Unknown parameter ... To do so I simply commented
part of my modprobe.conf:
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
options snd-via82xx index=0
remove snd-via82xx { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-via82xx
#alias snd-card-1 pwc
#options snd-card-1 index=1
#options pwc index=1
#remove pwc { /usr/sbin/alsactl store 1 >/dev/null 2>&1 || : ; }; /sbin/modprobe
-r --ignore-remove pwc

At the next reboot here is what I got:
pwc: Philips webcam module version 10.0.12 loaded.
pwc: Supports Philips PCA645/646, PCVC675/680/690, PCVC720[40]/730/740/750 &
PCVC830/840.
pwc: Also supports the Askey VC010, various Logitech Quickcams, Samsung MPC-C10
and MPC-C30,
pwc: the Creative WebCam 5 & Pro Ex, SOTEC Afina Eye and Visionite VCS-UC300 and
VCS-UM100.
pwc: Logitech QuickCam 4000 Pro USB webcam detected.
pwc: Registered as /dev/video0.
usbcore: registered new driver Philips webcam
usbcore: registered new driver snd-usb-audio

Looks like pwc driver finally worked all right.  Also, for no apparent reason my
sound worked fine in KDE... I tought that was it but after a second reboot there
was still no problems with pwc but my sound stoped working again.

Now I'll try to find out if either:
1- Any small change makes my sound working for one boot?
2- If the sound works randomly?

- vin
Comment 9 Harald Hoyer 2006-10-11 06:40:07 EDT
Well, I think the sound modules are loaded in a rather random order from udev.
So, maybe KDE tries to play the sound through the Webcam? :)
Comment 10 Th0ma7 2006-10-11 09:23:00 EDT
After a lot of reboots I think I can come to a some sort of conclusion...

It seems that, if I boot in runlvl4 and log in has my user I can always play a
wav file using aplay:
Fedora Core release 5.92 (FC6 Test3)
Kernel 2.6.18-1.2747.fc6 on an x86_64

th0ma7 login: megaloutre
Password:
Last login: Tue Oct 10 09:17:05 on tty1
[megaloutre@th0ma7]~% aplay /usr/share/sounds/info.wav
Playing WAVE '/usr/share/sounds/info.wav' : Signed 16 bit Little Endian, Rate
44100 Hz, Mono

If then I exit, relogin has root and type init 5 to get an X I will also be able
to get sound has my user...  So it seems to me that the only way I can get sound
is by first login in has my user into the console the login using the GUI?

Pretty strange?

- vin
Comment 11 Harald Hoyer 2006-10-11 09:50:24 EDT
no... first user that logs in on a console or X11 owns the "console devices"
like floppy, cdrom and sound..
Comment 12 Th0ma7 2006-10-11 21:09:44 EDT
Fine... easy answer... the problem is that sound is not working when I directly
log-in from GDM into my user account using KDE ...?

Although, if I first log-in from the console in runlvl 4, play a wav, log out,
log in has root, invoke runlvl 5, then log in using GDM into that same user
account... voila, sound do work.... The only problem is that I don't really plan
to do this at every reboots... ?!?
Comment 13 Harald Hoyer 2006-10-12 04:59:49 EDT
could you report the permissions of /dev/snd/* in both cases?
$ ls -l /dev/snd/*
and 
$ cat /proc/asound/cards
Comment 14 Th0ma7 2006-10-12 05:52:41 EDT
I'm starting to wonder if this is not totally random... The log-in has run-lvl
thing did not worked all right this morning... Only a cold reboot finally made
me have sound???  Could my sound card not always being detected?

When it does not work:
[megaloutre@th0ma7]~% ls -l /dev/snd/*
crw------- 1 megaloutre root 116, 5 Oct 12 05:24 /dev/snd/controlC0
crw------- 1 megaloutre root 116, 4 Oct 12 05:24 /dev/snd/pcmC0D0c
crw------- 1 megaloutre root 116, 3 Oct 12 05:24 /dev/snd/seq
crw------- 1 megaloutre root 116, 2 Oct 12 05:24 /dev/snd/timer
[megaloutre@th0ma7]~% cat /proc/asound/cards
 0 [U0x46d0x8b2    ]: USB-Audio - USB Device 0x46d:0x8b2
                      USB Device 0x46d:0x8b2 at usb-0000:00:10.1-1, full speed

When it does work.... 
[megaloutre@th0ma7]~% ls -l /dev/snd/*
crw------- 1 megaloutre root 116,  8 Oct 12 05:47 /dev/snd/controlC0
crw------- 1 megaloutre root 116, 10 Oct 12 05:47 /dev/snd/controlC1
crw------- 1 megaloutre root 116,  7 Oct 12 05:47 /dev/snd/pcmC0D0c
crw------- 1 megaloutre root 116,  6 Oct 12 05:47 /dev/snd/pcmC0D0p
crw------- 1 megaloutre root 116,  5 Oct 12 05:47 /dev/snd/pcmC0D1c
crw------- 1 megaloutre root 116,  4 Oct 12 05:47 /dev/snd/pcmC0D1p
crw------- 1 megaloutre root 116,  9 Oct 12 05:47 /dev/snd/pcmC1D0c
crw------- 1 megaloutre root 116,  3 Oct 12 05:47 /dev/snd/seq
crw------- 1 megaloutre root 116,  2 Oct 12 05:47 /dev/snd/timer
[megaloutre@th0ma7]~% cat /proc/asound/cards
 0 [V8237          ]: VIA8237 - VIA 8237
                      VIA 8237 with ALC850 at 0xe800, irq 209
 1 [U0x46d0x8b2    ]: USB-Audio - USB Device 0x46d:0x8b2
                      USB Device 0x46d:0x8b2 at usb-0000:00:10.1-1, full speed

Comment 15 Harald Hoyer 2006-10-12 06:37:39 EDT
kernel thing, then..
Comment 16 Harald Hoyer 2006-10-12 06:41:11 EDT
in the case of non-working, could you modprobe the sound module by hand?
attach /var/log/dmesg and look in /var/log/messages.
Comment 17 Th0ma7 2006-10-13 05:56:42 EDT
I've tried to make sound working again before going at work this morning without
any luck.. Although, here is what I got when it does not work properly:
[root@th0ma7 ~]# lsmod | sort > lsmod-NoSound.txt
[root@th0ma7 ~]# rmmod snd_via82xx
[root@th0ma7 ~]# lsmod | grep via
snd_via82xx_modem      50381  0
snd_ac97_codec        143769  1 snd_via82xx_modem
snd_pcm               125129  4
snd_via82xx_modem,snd_ac97_codec,snd_usb_audio,snd_pcm_oss
snd                   101737  13
snd_via82xx_modem,snd_ac97_codec,snd_mpu401_uart,snd_usb_audio,snd_seq_oss,snd_seq,snd_rawmidi,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_hwdep,snd_seq_device,snd_timer
i2c_viapro             42969  0
snd_page_alloc         44113  2 snd_via82xx_modem,snd_pcm
i2c_core               58177  5 w83627hf,eeprom,i2c_isa,i2c_ec,i2c_viapro
sata_via               44612  9
libata                143849  1 sata_via
[root@th0ma7 ~]# modprobe snd_via82xx
cannot find the slot for index 0 (range 0-1)
VIA 82xx Audio: probe of 0000:00:11.5 failed with error -12

modprobe.conf (note that I removed the alias on the webcam since it was causing
errors at boot time... see comment #7):
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
options snd-via82xx index=0
remove snd-via82xx { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-via82xx
#alias snd-card-1 pwc
#options snd-card-1 index=1
#options pwc index=1
#remove pwc { /usr/sbin/alsactl store 1 >/dev/null 2>&1 || : ; }; /sbin/modprobe
-r --ignore-remove pwc

dmesg (this makes me think that it might be an ACPI issue.. maybe a test with
acpi=off would be interesting...):
    338 Linux video capture interface: v2.00
    339 pwc: Philips webcam module version 10.0.12 loaded.
    340 pwc: Supports Philips PCA645/646, PCVC675/680/690,
PCVC720[40]/730/740/750 & PCVC830/840.
    341 pwc: Also supports the Askey VC010, various Logitech Quickcams, Samsung
MPC-C10 and MPC-C30,
    342 pwc: the Creative WebCam 5 & Pro Ex, SOTEC Afina Eye and Visionite
VCS-UC300 and VCS-UM100.
    343 pwc: Logitech QuickCam 4000 Pro USB webcam detected.
    344 pwc: Registered as /dev/video0.
    345 usbcore: registered new driver Philips webcam
....
    401 ACPI: PCI interrupt for device 0000:00:11.6 disabled
    402 VIA 82xx Modem: probe of 0000:00:11.6 failed with error -13
    403 cannot find the slot for index 0 (range 0-1)
    404 VIA 82xx Audio: probe of 0000:00:11.5 failed with error -12

Also note that there is a known bug with VIA chipset that makes irqbalance
create a real mess out of your system (jerky mouse, lan dropping, freeze).  For
thoses reasons I've already disabled irqbalance service (like I'm used to since
FC3 I think...).

Hope this helps?

- vin
Comment 18 Th0ma7 2007-10-24 21:10:08 EDT
Again, having the same type of problem with sound under KDE... 

All in all there are actually two totally different problems in this bug info:
1- Problem with the sound in KDE
2- Problem with the pwc driver interfering with the sound indexes slots.

Lets only handle the 2nd bug part....

I simply modified the udev rules to get everything working (see patch):
--- 40-alsa.rules       2007-10-24 20:57:19.000000000 -0400
+++ /etc/udev/rules.d/40-alsa.rules     2007-10-24 20:58:22.000000000 -0400
@@ -1,11 +1,11 @@
 # do not edit this file, it will be overwritten on update

-KERNEL=="controlC[0-9]*",      NAME="snd/%k"
-KERNEL=="hwC[D0-9]*",          NAME="snd/%k"
-KERNEL=="pcmC[D0-9cp]*",       NAME="snd/%k"
-KERNEL=="midiC[D0-9]*",                NAME="snd/%k"
-KERNEL=="timer",               NAME="snd/%k"
-KERNEL=="seq",                 NAME="snd/%k"
-KERNEL=="mixer0",              SYMLINK+="mixer"
-KERNEL=="dsp0",                        SYMLINK+="dsp"
-KERNEL=="audio0",              SYMLINK+="audio"
+KERNEL=="controlC[0-9]*",      NAME="snd/%k",          MODE="0660",OWNER="root"
+KERNEL=="hwC[D0-9]*",          NAME="snd/%k",          MODE="0660",OWNER="root"
+KERNEL=="pcmC[D0-9cp]*",       NAME="snd/%k",          MODE="0660",OWNER="root"
+KERNEL=="midiC[D0-9]*",                NAME="snd/%k",         
MODE="0660",OWNER="root"
+KERNEL=="timer",               NAME="snd/%k",          MODE="0660",OWNER="root"
+KERNEL=="seq",                 NAME="snd/%k",          MODE="0660",OWNER="root"
+KERNEL=="mixer0",              SYMLINK+="mixer",       MODE="0660",OWNER="root"
+KERNEL=="dsp0",                        SYMLINK+="dsp",        
MODE="0660",OWNER="root"
+KERNEL=="audio0",              SYMLINK+="audio",       MODE="0660",OWNER="root"

I presume it might not be the appropriate way to handle this but it worked :)
Comment 19 Harald Hoyer 2007-10-25 01:04:09 EDT
errr.. root is the default owner. and MODE is 0600. 
pam_console sets the owner of these files, after you log in to the console user.
I cannot see, how this should change things.
Comment 20 Pavel Roskin 2007-10-25 16:50:11 EDT
The old way would be to have the audio group and to make all users members of
that group.  Since such group doesn't exist, I assume the intention is to give
access to the audio to whoever is logged in locally.

The problem is, it's not working for me, neither in IceWM not in GNOME.  Perhaps
something is wrong with pam configuration files.  I checked contents of
pam-0.99.8.1-10.fc8.x86_64.rpm and I cannot find any references to /dev/snd.  I
think it should be in /etc/security/console.perms.d/50-default.perms or maybe
some ALSA package should install some other file under
/etc/security/console.perms.d/

On the other hand, pam-0.99.7.1-5.1.fc7 from Fedora 7 has /dev/snd/* listed in
/etc/security/console.perms.d/50-default.perms, so either the entry was lost by
mistake in F8, or is was moved to a file that is not guaranteed to be installed.
Comment 21 Chuck Ebbert 2007-10-25 17:03:11 EDT
Bug 287941 might be relevant here.
Comment 22 Pavel Roskin 2007-10-25 17:22:36 EDT
/dev/snd is removed from 50-default.perms by a patch called
pam-0.99.8.1-console-hal-handled.patch in the pam sources, so that shifts the
blame to HAL.  Bug 287941 mentions /var/lib/hal/acl-list, which is probably
relevant.  But I cannot figure out what's wrong on my systems.  I have a x86_64
and a i686 system with Fedora Development, both are up-to-date, and both have
/dev/snd/* owned by root.
Comment 23 Harald Hoyer 2007-10-26 02:06:31 EDT
in F8 ConsoleKit does the job pam_console did. Now with acls rather than with
user ownage. so be sure ConsoleKit is running.

# chkconfig ConsoleKit on
# service ConsoleKit start
Comment 24 Pavel Roskin 2007-10-26 12:30:20 EDT
I'm logged in with gdm as user proski (uid 500) and running this in xterm under su:

[root@dv proski]# service ConsoleKit status
console-kit-daemon (pid 26541) is running...
[root@dv proski]# chkconfig --list ConsoleKit
ConsoleKit      0:off   1:off   2:off   3:on    4:on    5:on    6:off

So, it's running.

[root@dv proski]# ls -al /dev/snd/
total 0
drwxr-xr-x   2 root root     220 Oct 26 09:59 .
drwxr-xr-x  12 root root    4420 Oct 26 10:00 ..
crw-rw----+  1 root root 116,  0 Oct 26 09:59 controlC0
crw-rw----+  1 root root 116, 24 Oct 26 09:59 pcmC0D0c
crw-rw----+  1 root root 116, 16 Oct 26 09:59 pcmC0D0p
crw-rw----+  1 root root 116, 25 Oct 26 09:59 pcmC0D1c
crw-rw----+  1 root root 116, 26 Oct 26 09:59 pcmC0D2c
crw-rw----+  1 root root 116, 27 Oct 26 09:59 pcmC0D3c
crw-rw----+  1 root root 116, 20 Oct 26 09:59 pcmC0D4p
crw-rw----+  1 root root 116,  1 Oct 26 09:59 seq
crw-rw----+  1 root root 116, 33 Oct 26 09:59 timer

Pluses indicate ACLs, I guess.

[root@dv proski]# getfacl /dev/snd/controlC0
getfacl: Removing leading '/' from absolute path names
# file: dev/snd/controlC0
# owner: root
# group: root
user::rw-
user:gdm:rw-
group::rw-
mask::rw-
other::---

So, the permission were given to user gdm (uid 42), not to user proski (uid 500).
Comment 25 Pavel Roskin 2007-10-26 13:11:35 EDT
I logged off in X and switched to the console (tty1) with Ctrl-Alt-F1.  I logged
in as root.  There were still additional permissions for gdm on
/dev/snd/controlC0.  Then I logged in as proski on tty2.  There were rw
permissions for both gdb and proski:

[proski@dv ~]$ getfacl -p /dev/snd/controlC0
# file: /dev/snd/controlC0
# owner: root
# group: root
user::rw-
user:gdm:rw-
user:proski:rw-
group::rw-
mask::rw-
other::---

Then I switched to tty1 with Alt-F1, and getfacl would show gdm but not proski.
 I switched to tty2, and proski was back.  I ran alsamixer, and it worked.  I
switched to tty1 and back to tty2, and alsamixed would not work.  Then I ran
getfacl many times, and "proski" would appear and disappear, and alsamixer
started working again.

Then I logged out on the console and logged in with gdm.  "proski" was in
getfacl output, an alsamixer worked.

I cannot make sense of all that.  It's like the rw permissions for proski are
added and removed randomly.  This is consistent with other users saying that
alsamixer is working on some "good days".
Comment 26 Chuck Ebbert 2007-10-26 17:22:32 EDT
Are you sure everything is up-to-date? I had this problem and it was fixed by
the recent updates.

What version of selinux-policy-targeted and xorg-x11-xinit do you have?

Also, try booting to runlevel 3 and starting X with the startx command.
Comment 27 Pavel Roskin 2007-10-27 01:15:06 EDT
My observations were made on a x86_64 system, which has xorg-x11-xinit
1.0.7-2.fc8 and no selinux-policy-targeted.  I rebooted it, and it's working
properly.  Perhaps I forgot to reboot after some updates.

The i686 system has xorg-x11-xinit 1.0.7-2.fc8 and selinux-policy-targeted
3.0.8-32.fc8.  It's also working properly now.

startx is working properly too.
Comment 28 Harald Hoyer 2007-10-27 04:28:26 EDT
> I cannot make sense of all that.  It's like the rw permissions for proski are
> added and removed randomly.  This is consistent with other users saying that
> alsamixer is working on some "good days".
Comment 29 Th0ma7 2007-10-27 12:19:55 EDT
I reverted the udev rules file to the original state and sound was back to not
being usable...

Anyhow, I tested the runlvl 3 with startx has my normal user account with no
luck.. still no sound available..

here are the version I have:
[root@gustav ~]# rpm -qa | grep -i xorg-x11-xinit
xorg-x11-xinit-1.0.7-2.fc8
[root@gustav ~]# rpm -qa | grep -i selinux-policy-targeted
selinux-policy-targeted-3.0.8-33.fc8

I'll try to use GDM instead of KDM and see what it does by removing the entry in
the desktop file:
[root@gustav ~]# more /etc/sysconfig/desktop
DISPLAYMANAGER=KDE
Comment 30 Th0ma7 2007-10-27 12:22:12 EDT
no luck either using GDM... still getting the error msg:
Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (Connection refused)
The sound server will continue, using the null output device.
Comment 31 Th0ma7 2007-10-28 08:30:49 EDT
I now wonder... may theses be somehow related?
https://bugzilla.redhat.com/show_bug.cgi?id=344181
Comment 32 Pavel Roskin 2007-10-28 13:05:11 EDT
It may be related if you are using a custom kernel with ACLs disabled.  Check
the kernel configuration.  Maybe you should try the stock kernel.  Check if
ConsoleKit is running.  Try "getfacl /dev/snd/*" to see if you have ACLs working
and there is an entry giving rw permissions for the logged in user.  Try using
setfacl to see if ACLs can be modified.
Comment 33 Chuck Ebbert 2007-10-29 13:30:20 EDT
(In reply to comment #30)
> no luck either using GDM... still getting the error msg:
> Sound server informational message:
> Error while initializing the sound driver:
> device: default can't be opened for playback (Connection refused)
> The sound server will continue, using the null output device.

That is because puleseaudio is not running.
Either uninstall pulseaudio and alsa-plugins-pulseaudio,
or install kde-settings-pulseaudio.
Comment 34 Th0ma7 2007-10-30 05:54:53 EDT
Most probably due to new updates sound is now always present in KDE ?!? Horray!

[root@gustav ~]# rpm -qa | grep -e xorg-x11-xinit -e selinux-policy-targeted
selinux-policy-targeted-3.0.8-36.fc8
xorg-x11-xinit-1.0.7-2.fc8

I would have liked to know what fixed it but hey, at least it now works.

Note You need to log in before you can comment on or make changes to this bug.