Bug 210135 - pup crash
pup crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 210115 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 08:17 EDT by Matthias Clasen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-10 22:34:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-10-10 08:17:24 EDT
This was observed while doing an update with pirut 1.2.3-1

Component: Software Updater
Summary: TB9b21e18b mirror.py:385:_mirror_try:KeyError: 'failure_callback'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 354, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 530, in
applyChanges
    dlpkgs = self.downloadPackages(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 272, in
downloadPackages
    probs = self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 690, in downloadPkgs
    cache=po.repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 466, in getPackage
    cache=cache
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 451, in __get
    http_headers=headers,
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 411, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 397, in
_mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 927, in
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 845, in _retry
    r = apply(func, (opts,) + args, {})
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 922, in
retryfunc
    apply(cb_func, (obj, )+cb_args, cb_kwargs)
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 385, in
_mirror_try
    try: del kw[k]
KeyError: 'failure_callback'

Local variables in innermost frame:
gr: <urlgrabber.mirror.GrabRequest instance at 0xa7024ac>
url: Fedora/RPMS/glibc-devel-2.5-3.i386.rpm
k: failure_callback
mirrorchoice: {'mirror':
'http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/os/'}
self: <urlgrabber.mirror.MGRandomOrder instance at 0xa70bdac>
grabber: <urlgrabber.grabber.URLGrabber instance at 0xa70b2ec>
func_ref: <bound method URLGrabber.urlgrab of <urlgrabber.grabber.URLGrabber
instance at 0xa70b2ec>>
func: urlgrab
kwargs: {'range': (None, None), 'checkfunc': (<bound method
PackageUpdater.verifyPkg of <__main__.PackageUpdater object at 0x9b11f8c>>,
(<yum.sqlitesack.YumAvailablePackageSqlite instance at 0xa45418c>, 1), {}),
'copy_local': 0, 'http_headers': (), 'text': '(3/59):
glibc-devel-2.5-3.i386.rpm', 'reget': 'simple', 'filename':
'//var/cache/yum/development/packages/glibc-devel-2.5-3.i386.rpm'}
kw: {'range': (None, None), 'checkfunc': (<bound method PackageUpdater.verifyPkg
of <__main__.PackageUpdater object at 0x9b11f8c>>,
(<yum.sqlitesack.YumAvailablePackageSqlite instance at 0xa45418c>, 1), {}),
'copy_local': 0, 'http_headers': (), 'text': '(3/59):
glibc-devel-2.5-3.i386.rpm', 'reget': 'simple', 'filename':
'//var/cache/yum/development/packages/glibc-devel-2.5-3.i386.rpm'} 
fullurl:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/os/Fedora/RPMS/glibc-devel-2.5-3.i386.rpm
Comment 1 Jeremy Katz 2006-10-10 22:34:54 EDT
Fixed in yum-3.0-4. 
Comment 2 Jeremy Katz 2006-10-10 22:36:28 EDT
*** Bug 210115 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.