This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 210140 - Python GIL is held when calling into C functions, blocking whole interpreter
Python GIL is held when calling into C functions, blocking whole interpreter
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 09:01 EDT by Daniel Berrange
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 20:14:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2006-10-10 09:01:42 EDT
Description of problem:
When calling into C functions from the libvirt python binding, the Global
Interpreter Lock is held. This means that even if the Python application is
multi-threaded, the entire application will appear to hang until the C function
completes. This is a big problem for virt-manager because the VM create
operation can take a non-trivial amount of time

Version-Release number of selected component (if applicable):
libvirt-python-0.1.7-2

How reproducible:
Frequently

Steps to Reproduce:
1. Launch virt-manager
2. Create a new domain
3.
  
Actual results:
The progress dialog popped up when creating the domain freezes for several seconds

Expected results:
The progress dialog runs smoothly with no interruption

Additional info:
Prototype fix posted upstream

https://www.redhat.com/archives/libvir-list/2006-October/msg00007.html
Comment 1 RHEL Product and Program Management 2006-10-26 15:19:47 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Daniel Veillard 2006-10-26 17:44:19 EDT
We already have a tested working patch for this applied upstream (drom Dan 
Berrange), no problem devel wise,

Daniel
Comment 4 Jay Turner 2006-12-06 22:42:40 EST
QE ack for RHEL5.
Comment 5 Daniel Veillard 2006-12-07 08:39:54 EST
libvirt-0.1.8-7.el5 has been built carrying the patch, that should fix it !

Daniel
Comment 6 RHEL Product and Program Management 2006-12-22 20:14:06 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.