Bug 210241 - sar error in Redhat AS 4 update 3
sar error in Redhat AS 4 update 3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sysstat (Show other bugs)
4.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Brian Brock
:
: 210242 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 17:58 EDT by Marty
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version: sysstat-5.0.5-14.rhel4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-02 07:36:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output file of /usr/lib/sa/sadc 5 5 (13.09 KB, application/octet-stream)
2006-10-11 14:23 EDT, Marty
no flags Details

  None (edit)
Description Marty 2006-10-10 17:58:03 EDT
Description of problem: 

sar is reporting error everytime.  Have several servers running update as 4 
update 2 and only see this in update 3.
 
Everytime running sar with interval number getting - "Please give a smaller 
interval value"

Example- 

root@server ~ # sar 1 1
Linux 2.6.9-22.ELsmp (lnx276)   10/10/2006

03:45:36 PM       CPU     %user     %nice   %system   %iowait     %idle
03:45:37 PM       all      0.00      0.00      0.00      0.00      0.00
Please give a smaller interval value
root@server ~ # sar 1 2
Linux 2.6.9-22.ELsmp (lnx276)   10/10/2006

03:45:47 PM       CPU     %user     %nice   %system   %iowait     %idle
03:45:48 PM       all      0.00      0.00      0.00      0.00      0.00
03:45:49 PM       all      0.00      0.00      0.00      0.00      0.00
Please give a smaller interval value
root@server ~ # sar 2 2
Linux 2.6.9-22.ELsmp (lnx276)   10/10/2006

03:45:56 PM       CPU     %user     %nice   %system   %iowait     %idle
03:45:58 PM       all      0.00      0.00      0.00      0.00      0.00
03:46:00 PM       all      0.00      0.00      0.00      0.00      0.00
Please give a smaller interval value


Version-Release number of selected component (if applicable):

sysstat-5.0.5-11.rhel4
Red Hat Enterprise Linux AS release 4 (Nahant Update 3)
2.6.9-22.ELsmp #1 SMP Mon Sep 19 18:32:14 EDT 2005 i686 i686 i386 GNU/Linux
How reproducible:
Everytime


Steps to Reproduce:
1.run "sar number number"
2.
3.
  
Actual results:

Expected results:


Additional info:
Comment 1 Ivana Varekova 2006-10-11 03:35:15 EDT
*** Bug 210242 has been marked as a duplicate of this bug. ***
Comment 2 Ivana Varekova 2006-10-11 07:49:10 EDT
I try to reproduce this problem with both rhel4u3 and rhel4u4 versions but I was
unsuccesfull - everything was ok. 
Please which version of sysstat do you use? (In rhel4 update 3 there is
sysstat-5.0.5-7.rhel4 and in rhel4 update4 there is sysstat-5.0.5-11.rhel) - you
write you have rhel4u3, but the sysstat seems to be newer.
Could you attach the output file from sadc command ('/usr/lib/sa/sadc 5 5 -f
output' - or if you have 64 bit architecture '/usr/lib64/sa/sadc 5 5 -f output').
Comment 3 Marty 2006-10-11 14:23:15 EDT
Created attachment 138266 [details]
output file of /usr/lib/sa/sadc 5 5
Comment 4 Marty 2006-10-11 14:26:01 EDT
The original sysstat at installation was sysstat-5.0.5-7.rhel4 the error was 
discovered and upgraded sysstat-5.0.5-11.rhel4 where the error still exists
Comment 5 Ivana Varekova 2006-10-13 10:25:08 EDT
I'm still not able to reproduce your problem. Please could you try to reproduce
the bug with the test version of sysstat package - 
http://people.redhat.com/varekova/sysstat-5.0.5-14.rhel4.TEST.i386.rpm
and attach the output of sar command here. 
Comment 6 Marty 2006-10-13 12:29:24 EDT
root@server /tmp # sar 1 1
Linux 2.6.9-22.ELsmp (lnx276)   10/13/2006

10:28:05 AM       CPU     %user     %nice   %system   %iowait     %idle
10:28:06 AM       all      0.00      0.00      0.50      0.50     99.00
u  6980087   6980087  |n     2653     2653 |s  5520274  5520276 |i    
5682138    5682140 |d 1065493140 1065493537 ||
 ||2 1083678292 1083678693 -      401  |1 1344633400 1344633501 -      101 
|        401
--- 2 1083678693 1083678292 -      401  |1 1083678693 1344633400 -      101 
|        401        101 ---
Average:          all      0.00      0.00      0.50      0.50     99.00
u  6980087   6980087  |n     2653     2653 |s  5520274  5520276 |i    
5682138    5682140 |d 1065493140 1065493537 ||
 ||2 1083678292 1083678693 -      401  |1 1344633400 1344633501 -      101 
|        401
root@server /tmp # sar 1 2
Linux 2.6.9-22.ELsmp (lnx276)   10/13/2006

10:28:11 AM       CPU     %user     %nice   %system   %iowait     %idle
10:28:12 AM       all      0.00      0.00      0.00      0.00    100.00
u  6980087   6980087  |n     2653     2653 |s  5520276  5520276 |i    
5682140    5682140 |d 1065495190 1065495591 ||
 ||2 1083680346 1083680747 -      401  |1 1344633914 1344634014 -      100 
|        401
10:28:13 AM       all      0.00      0.00      0.00      0.00    100.00
u  6980087   6980087  |n     2653     2653 |s  5520276  5520276 |i    
5682140    5682140 |d 1065495591 1065495991 ||
 ||2 1083680747 1083681147 -      400  |1 1344634014 1344634114 -      100 
|        400
--- 2 1083681147 1083680346 -      801  |1 1083681147 1344633914 -      200 
|        801        200 ---
Average:          all      0.00      0.00      0.00      0.00    100.00
u  6980087   6980087  |n     2653     2653 |s  5520276  5520276 |i    
5682140    5682140 |d 1065495190 1065495991 ||
 ||2 1083680346 1083681147 -      801  |1 1344633914 1344634114 -      200 
|        801
root@server /tmp # sar 2 2
Linux 2.6.9-22.ELsmp (lnx276)   10/13/2006

10:28:18 AM       CPU     %user     %nice   %system   %iowait     %idle
10:28:20 AM       all      0.00      0.00      0.00      0.00    100.00
u  6980087   6980087  |n     2653     2653 |s  5520277  5520277 |i    
5682140    5682140 |d 1065498089 1065498889 ||
 ||2 1083683246 1083684046 -      800  |1 1344634639 1344634839 -      200 
|        800
10:28:22 AM       all      0.00      0.00      0.00      0.00    100.00
u  6980087   6980087  |n     2653     2653 |s  5520277  5520277 |i    
5682140    5682140 |d 1065498889 1065499689 ||
 ||2 1083684046 1083684846 -      800  |1 1344634839 1344635039 -      200 
|        800
--- 2 1083684846 1083683246 -     1600  |1 1083684846 1344634639 -      400 
|       1600        400 ---
Average:          all      0.00      0.00      0.00      0.00    100.00
u  6980087   6980087  |n     2653     2653 |s  5520277  5520277 |i    
5682140    5682140 |d 1065498089 1065499689 ||
 ||2 1083683246 1083684846 -     1600  |1 1344634639 1344635039 -      400 
|       1600
Comment 7 Marty 2006-10-13 12:39:29 EDT
The sar command is now reporting CPU usage correctly which if look at my first 
output it reported 0% on idle while the system was 100% idle.  So this is 
definite progress.  Thank You
Comment 8 Ivana Varekova 2006-10-16 07:19:23 EDT
In sysstat-5.0.5-14.rhel4.TEST there were fixed another problems - there was
only added verbose output to test your problem. But it seems the previous
version fixes  your problem too. Could you please test the package without
verbose output - 
http://people.redhat.com/varekova/sysstat-5.0.5-14.rhel4.i386.rpm. 
Comment 9 Marty 2006-10-20 12:15:29 EDT
Excellent!  Looks like this is fixed.


root@server ~ # sar 1 1
Linux 2.6.9-22.ELsmp (lnx276)   10/20/2006

10:04:38 AM       CPU     %user     %nice   %system   %iowait     %idle
10:04:39 AM       all      0.25      0.00      0.00      0.00     99.75
Average:          all      0.25      0.00      0.00      0.00     99.75
root@server ~ # sar 1 2
Linux 2.6.9-22.ELsmp (lnx276)   10/20/2006

10:04:41 AM       CPU     %user     %nice   %system   %iowait     %idle
10:04:42 AM       all      0.00      0.00      0.00      0.00    100.00
10:04:43 AM       all      0.00      0.00      0.00      0.00    100.00
Average:          all      0.00      0.00      0.00      0.00    100.00
root@server ~ # sar 2 2
Linux 2.6.9-22.ELsmp (lnx276)   10/20/2006

10:04:51 AM       CPU     %user     %nice   %system   %iowait     %idle
10:04:53 AM       all      0.00      0.00      0.00      0.00    100.00
10:04:55 AM       all      0.00      0.00      0.12      0.00     99.88
Average:          all      0.00      0.00      0.06      0.00     99.94
Comment 10 Ivana Varekova 2007-05-02 07:36:47 EDT
This problem is fixed in sysstat-5.0.5-14.rhel4, if the problem persists after
the upgrade to 14.rhel4, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.