Bug 210246 - POP UIDL conversion between UW-POP3 and DoveCot
POP UIDL conversion between UW-POP3 and DoveCot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dovecot (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Janousek
http://wiki.dovecot.org/Migration
:
: 210368 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 18:14 EDT by kevin getbehead
Modified: 2007-11-16 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0269
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 18:47:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to address issues with dovecot migration from IMAP to POP3. (655 bytes, patch)
2006-10-11 15:00 EDT, Bryan Mason
no flags Details | Diff
dovecot-0.99.11-uw-compat.patch (3.08 KB, patch)
2006-10-24 05:14 EDT, Petr Rockai
no flags Details | Diff
dovecot-0.99.11-uw-compat.patch (3.09 KB, patch)
2006-10-24 11:17 EDT, Petr Rockai
no flags Details | Diff
RPM containing patch dovecot-0.99.11-uw-compat.patch (611.60 KB, application/x-rpm)
2006-11-06 09:48 EST, David E. Cox
no flags Details

  None (edit)
Description kevin getbehead 2006-10-10 18:14:14 EDT
Description of problem:
DoveCot 0.99 does not recognize the UID message IDs used by UW-POP3 (from RHEL3). 

Version-Release number of selected component (if applicable):
0.99

How reproducible:
Convert email inbox from RHEL3 running UW-POP3 mbox, to RHEL4 running DoveCot
0.99 (maildir).

Steps to Reproduce:
1. View message UIDs:
$telnet localhost 110
user test
pass test
uidl
quit
2.Convert email inbox from RHEL3 running UW-POP3 mbox, to RHEL4 running DoveCot
0.99 (maildir)
3. View message UIDs:
$telnet localhost 110
user test
pass test
uidl
quit

  
Actual results:
UIDs from UW-POP are not recognized by DoveCot. Therefore all converted email is
flagged as new and un-read.

Expected results:
DoveCot should recognize the UW-POP3 UIDL convention, and recognize whether or
not individual pieces of email have been viewed/downloaded/read.

Additional info:
The issue has been patched by dovecot, but redhat has not released the patch
into there environment (as far as I can tell).
The issue has also been fixed in DoveCot 1.0, with the new "pop3_uidl_format"
parameter.
Please reference:
http://wiki.dovecot.org/Migration
Comment 1 Petr Rockai 2006-10-11 14:37:41 EDT
*** Bug 210368 has been marked as a duplicate of this bug. ***
Comment 2 Marco Bill-Peter 2006-10-11 14:54:45 EDT
customer LPL just run into this problem. This is holding a large migration.

Requesting exception for 4.5
Comment 3 Bryan Mason 2006-10-11 15:00:44 EDT
Created attachment 138271 [details]
Patch to address issues with dovecot migration from IMAP to POP3.

From http://dovecot.org/patches/old/pop3-uidl-uwimap.patch.
Comment 4 RHEL Product and Program Management 2006-10-11 15:02:08 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Petr Rockai 2006-10-11 17:15:18 EDT
All nice and clear, but changing UIDL format in 4.5 will break migration from 
4.4. So the proposed patch is a no-go in an update. The only way i find 
acceptable is to add an option to flip uidl format to UW, defaulting to no. 
Installations migrating from UW would have to have that option changed 
manually. Is that reasonable?
Comment 6 kevin getbehead 2006-10-11 18:59:56 EDT
The option to flip UIDL formats is acceptable (i.e., uidl_format_uw=no). Setting
the default to something other than UW and being forced to manually set the
parameter to UW, is also acceptable. 
The ideal situation is to be able to specify the UIDL format, such as
"pop3_uidl_format = %08Xv%08Xu". It looks as though this is the direction
dovecot is heading, in version 1.0

Comment 7 Petr Rockai 2006-10-17 09:36:36 EDT
We will proceed with the uw-compat flag solution, as pop3_uidl_format would 
require backporting nontrivial amount of code.
Comment 10 Petr Rockai 2006-10-24 05:14:45 EDT
Created attachment 139204 [details]
dovecot-0.99.11-uw-compat.patch

Proposed patch.
Comment 12 Petr Rockai 2006-10-24 11:17:25 EDT
Created attachment 139232 [details]
dovecot-0.99.11-uw-compat.patch

Fixed a problem with the patch.
Comment 13 David E. Cox 2006-11-06 09:48:07 EST
Created attachment 140481 [details]
RPM containing patch dovecot-0.99.11-uw-compat.patch
Comment 14 Giovanni 2006-12-06 16:37:41 EST
Why the rpm is not released officially by RedHat?
I think is the better solution. So the system administrator can choose as
configure own system.
Comment 16 Sergio Patrucco 2007-02-01 05:55:25 EST
Thank you RedHat for your "easy to use and migrate" systems. 
Perhaps email is not a critical service for you, since you don't officialy
release a patch for this issue.
Did you test the migration from RHES3 to RHES4 before releasing the new version?
Please test it before releasing RHES5.... 
Comment 18 Tomas Janousek 2007-02-28 08:21:20 EST
We will release a patch for this issue in RHEL4.5.
Comment 21 Red Hat Bugzilla 2007-05-01 18:47:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0269.html

Note You need to log in before you can comment on or make changes to this bug.