This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 210268 - Grant table operations unsuitable for guest domains
Grant table operations unsuitable for guest domains
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Herbert Xu
Martin Jenner
:
Depends On:
Blocks: 210489
  Show dependency treegraph
 
Reported: 2006-10-11 01:46 EDT by Herbert Xu
Modified: 2008-02-26 18:30 EST (History)
4 users (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 18:30:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Restrict grant table hypercall to I/O domains. (1.74 KB, patch)
2006-10-11 01:46 EDT, Herbert Xu
no flags Details | Diff
Restrict grant table operations to dom0. (1.10 KB, patch)
2006-11-06 17:39 EST, Herbert Xu
no flags Details | Diff

  None (edit)
Comment 1 Herbert Xu 2006-10-11 01:46:09 EDT
Created attachment 138220 [details]
Restrict grant table hypercall to I/O domains.
Comment 2 Stephen Tweedie 2006-11-02 11:47:10 EST
What's the status on this upstream?  I don't see it in xen-unstable yet, should
we be pushing it to FC5/6 yet?
Comment 3 Herbert Xu 2006-11-06 13:22:20 EST
The last reply from upstream was:

> Now that we have rx copy path the transfer grants are obsolete anyway. Maybe
> we should just limit usage to domain-0 and be done.
>
>  -- Keir

I'll send an updated patch that just restricts this to dom0.  We don't support
I/O domains in FC6/RHEL5, right?
Comment 4 Herbert Xu 2006-11-06 17:39:36 EST
Created attachment 140523 [details]
Restrict grant table operations to dom0.

I just sent this path to Keir.
Comment 5 Stephen Tweedie 2006-11-06 17:40:31 EST
Yes, we do --- we compile in pcifront/back, and I have tested a NIC driver from
domU for FC6.
Comment 6 Herbert Xu 2006-11-13 01:53:53 EST
If we do then we'll need to stick with the earlier patch which restricted
operations to I/O domains instead of dom0.
Comment 7 Herbert Xu 2006-11-27 21:47:51 EST
This patch is now in FC6/RHEL5 as well as upstream.
Comment 8 Matthew Miller 2007-04-06 13:03:34 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 9 Red Hat Bugzilla 2007-07-24 19:59:51 EDT
change QA contact
Comment 10 Chris Lalancette 2008-02-26 18:30:43 EST
Since this seemed to make it into FC6 eventually, closing as CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.