This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 210277 - Compiz and xen crashes
Compiz and xen crashes
Status: CLOSED DUPLICATE of bug 207432
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-11 04:17 EDT by Daniel Malmgren
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-19 07:26:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2006-10-11 04:17:54 EDT
Description of problem:
Trying to start compiz crashes when my computer is booted with a xen kernel.

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-1.2747.fc6
xen-3.0.2-44
compiz-0.0.13-0.32.20060817git.fc6

How reproducible:
100%

Steps to Reproduce:
1. Boot computer using a xen kernel
2. Try starting compiz
  
Actual results:
Either the computer freezes so hard I've got to use the power switch to fix it,
or it simply reboots by itself.

Additional info:
System works perfectly nice when booted with non xen kernel. It also works very
nice in xen mode when using metacity (exactly same xorg config).

This is on a Znote6015WD laptop with Core2Duo processor running x86_64 Fedora.

Is there any way that I can extract any more useful information?
Comment 1 Stephen Tweedie 2006-10-11 12:33:14 EDT
Hmm.  If you have a serial port on the laptop then serial console ought to be
helpful.  If not, then netconsole may work, depending on what sort of ethernet
controller it has.
Comment 2 Daniel Malmgren 2006-10-12 05:23:00 EDT
A modern laptop with a serial port? ;-)

I think I need some help with getting the netconsole to work. I've done the
following:

On the laptop (10.11.22.102):
# modprobe netconsole
# netconsole=@10.11.22.102/eth0,6666@10.11.22.52/00:30:05:89:96:D5
...and disabled the firewall for udp 6666

On my other machine (10.11.22.52):
# nc -u -l 6666
...and likewisely disabled the firewall

This does not seem to do the trick.

I've got no kernel source installed. Where do I find the netlogging.txt file?
Comment 3 Steven Rostedt 2006-10-16 17:27:51 EDT
Looks like you did the netconsole options on a separate line.  Try again like this:

# modprobe netconsole
netconsole=@10.11.22.102/eth0,6666@10.11.22.52/00:30:05:89:96:D5

That might work better. Unless it was just a typo on this bz comment.

Also, test out the logging with a "echo m > /proc/sysrq-trigger"

You can get the netconsole documentation from the kernel source at kernel.org. 
It's in Documentation/networking/netconsole.txt.  I don't know about a
netlogging.txt file.
Comment 4 Steven Rostedt 2006-10-17 10:45:08 EDT
Make sure the options and modprobe of netconsole are on the same line ( I should
have put a backslash there). Like

# modprobe netconsole \
netconsole=@10.11.22.102/eth0,6666@10.11.22.52/00:30:05:89:96:D5

Comment 5 Daniel Malmgren 2006-10-19 07:24:29 EDT
I'd just like to note that I'll probably not get any useful debug output out
from this computer. The only way I have got my network to work is using
NetworkManager, and I can't seem to get NetworkManager to put the net up in any
other way than using the nm-applet. And I can't reach the nm-applet without X,
which doesn't work. Which is also different from what I first reported, because
then I succeeded to start X. Well, whatever. I'm quite sure now that this bug is
a dupe of 207432, since what Naoki describes fits perfectly well on my system
right now. Closing.
Comment 6 Daniel Malmgren 2006-10-19 07:26:12 EDT

*** This bug has been marked as a duplicate of 207432 ***
Comment 7 Naoki 2006-10-19 07:32:31 EDT
I'm not running compiz though, and 207432 is listed as a duplicate of this ticket.
Comment 8 Daniel Malmgren 2006-10-19 08:15:06 EDT
(In reply to comment #7)
> I'm not running compiz though, and 207432 is listed as a duplicate of this ticket.

I'm quite sure now that it had nothing with Compiz to do. It's just simply X
being very unstable and happened to crash while I was starting Compiz twice.

And no, 207432 is not listed as a duplicate of this, it's the other way. Makes a
world of difference ;-)

Note You need to log in before you can comment on or make changes to this bug.