Bug 210283 - [RHEL4] When the port number for the outgoing is specified by the rpc.statd -o command, the specified port number is not generated.
[RHEL4] When the port number for the outgoing is specified by the rpc.statd -...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
: 192799 206958 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-11 06:17 EDT by Jose Plans
Modified: 2010-10-22 02:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-0316
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 19:26:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpc.statd -o fix. (1.23 KB, patch)
2006-10-11 06:17 EDT, Jose Plans
no flags Details | Diff
a patch that applies to current nfs-utils (1.08 KB, patch)
2006-10-19 21:35 EDT, Steve Dickson
no flags Details | Diff

  None (edit)
Description Jose Plans 2006-10-11 06:17:11 EDT
Description of problem:

When the port number for the outgoing is specified by the rpc.statd -o command,
 the specified port number is not generated.
  
  ex.) specified number: 7777

[root@RHEL4U4]# service nfslock stop
Stopping NFS locking:                                      [  OK  ]
Stopping NFS statd:                                        [  OK  ]

[root@RHEL4U4]# rpc.statd -o 7777

[root@RHEL4U4]# rpcinfo -p
  program vers proto   port
   100000    2   tcp    111  portmapper
   100000    2   udp    111  portmapper
   100021    1   udp  32768  nlockmgr
   100021    3   udp  32768  nlockmgr
   100021    4   udp  32768  nlockmgr
   100021    1   tcp  32772  nlockmgr
   100021    3   tcp  32772  nlockmgr
   100021    4   tcp  32772  nlockmgr
   100024    1   udp   1001  status
   100024    1   tcp   1004  status

[root@RHEL4U4]# lsof -i
COMMAND     PID USER   FD   TYPE DEVICE SIZE NODE NAME
......................................................................... ......
portmap   2328  rpc    4u  IPv4   5028       UDP *:sunrpc
portmap   2328  rpc    5u  IPv4   5029       TCP *:sunrpc (LISTEN)
rpc.statd 3790 root    4u  IPv4   8809       UDP *:1001
rpc.statd 3790 root    5u  IPv4   8801       UDP *:998 ⇒ outgoing_port
==================================================
rpc.statd 3790 root    6u  IPv4   8812       TCP *:1004 (LISTEN)

Version-Release number of selected component (if applicable):
2.6.9-42.EL + nfs-utils-1.0.6-70.EL4

How reproducible:
Every Time

Additional info:

If we apply this patch backported from rawhide, lsof -i will show us the
outbound port correctly setup to 7777.

--
portmap   4362  rpc    3u  IPv4  10291       UDP *:sunrpc
portmap   4362  rpc    4u  IPv4  10292       TCP *:sunrpc (LISTEN)
rpc.statd 4510 root    4u  IPv4  10845       UDP *:rsync
rpc.statd 4510 root    5u  IPv4  10837       UDP *:870
rpc.statd 4510 root    6u  IPv4  10848       TCP *:876 (LISTEN)
rpc.rquot 9194 root    3u  IPv4  15987       UDP *:891
rpc.rquot 9194 root    4u  IPv4  15993       TCP *:894 (LISTEN)
rpc.mount 9211 root    6u  IPv4  16039       UDP *:907
rpc.mount 9211 root    7u  IPv4  16042       TCP *:910 (LISTEN)
rpc.statd 9226 root    4u  IPv4  16166       UDP *:924
rpc.statd 9226 root    5u  IPv4  16158       UDP *:7777 <----
rpc.statd 9226 root    6u  IPv4  16169       TCP *:927 (LISTEN)
--
Comment 1 Jose Plans 2006-10-11 06:17:12 EDT
Created attachment 138233 [details]
rpc.statd -o fix.
Comment 2 RHEL Product and Program Management 2006-10-11 13:01:51 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Steve Dickson 2006-10-19 21:35:50 EDT
Created attachment 138932 [details]
a patch that applies to current nfs-utils
Comment 4 Steve Dickson 2006-10-19 21:42:36 EDT
fixed in nfs-utils-1.0.6-74
Comment 5 Steve Dickson 2006-10-30 14:28:10 EST
*** Bug 192799 has been marked as a duplicate of this bug. ***
Comment 6 Steve Dickson 2006-10-30 20:52:48 EST
*** Bug 206958 has been marked as a duplicate of this bug. ***
Comment 7 Richard Cunningham 2006-10-31 07:02:48 EST
Is there somewhere I can get hold of the nfs-utils-1.0.6-74 package?
Comment 8 Steve Dickson 2006-10-31 18:50:41 EST
http://people.redhat.com/steved/bz210283/ 

let now if you need a different arch... 
Comment 12 Thomas Moschny 2007-02-21 11:48:41 EST
(In reply to comment #8)
> http://people.redhat.com/steved/bz210283/ 

This link doesn't work, and I can't see anything newer than nfs-utils-1.0.6-70.EL4 
here (for ia64).
Comment 15 Red Hat Bugzilla 2007-05-01 19:26:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0316.html

Note You need to log in before you can comment on or make changes to this bug.