Bug 210302 - LVM-Volumes with active Snapshots are not readable after Reboot
LVM-Volumes with active Snapshots are not readable after Reboot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Petr Rockai
Brock Organ
:
: 201354 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-11 09:46 EDT by Juergen Maniera
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2007-0287
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 20:10:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Maniera 2006-10-11 09:46:21 EDT
Description of problem:

If you reboot a System using LVM with an active Snapshot for a partition this
partition will not be readable at reboot any more :-(
As a workaround I had to add the following line into rc.sysinit
   
  modprobe dm_snapshot

before the LVM initialization starts
# LVM2 initialization
...

But maybe there is a more elegant way?


Version-Release number of selected component (if applicable):
initscripts-7.93.25.EL-1
lvm2-2.02.06-6.0.RHEL4
Linux version 2.6.9-42.0.3.ELsmp (brewbuilder@hs20-bc1-7.build.redhat.com) (gcc
version 3.4.6 20060404 (Red Hat 3.4.6-3)) #1 SMP Mon Sep 25 17:28:02 EDT 2006


How reproducible:

see above

Thank you and regards
 Juergen Maniera
Comment 1 Bill Nottingham 2006-10-11 11:06:50 EDT
What is the error message you get?
Comment 2 Juergen Maniera 2006-10-13 08:27:20 EDT
Sorry but I hat no time to note it, because this bug occured on a central server
I had to get running asap :-( But /dev/mapper/vg-... could not be mounted,
because there was no valid file system found.

This bug can also be found here:
http://bugs.centos.org/view.php?id=1141
Comment 10 Alasdair Kergon 2006-12-22 11:14:34 EST
should be fixed in 2.02.15 - please test
Comment 11 Alasdair Kergon 2006-12-22 11:18:49 EST
*** Bug 201354 has been marked as a duplicate of this bug. ***
Comment 14 Corey Marthaler 2007-01-24 14:29:42 EST
marking this verified based on comment #13
Comment 22 Red Hat Bugzilla 2007-05-07 20:10:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0287.html

Note You need to log in before you can comment on or make changes to this bug.