Bug 210368 - POP3 clients re-download all messages after converstion from UW-IMAP
POP3 clients re-download all messages after converstion from UW-IMAP
Status: CLOSED DUPLICATE of bug 210246
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dovecot (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-11 14:10 EDT by Bryan Mason
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-11 14:37:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to address issues with dovecot migration from IMAP to POP3. From http://dovecot.org/patches/old/pop3-uidl-uwimap.patch. (655 bytes, patch)
2006-10-11 14:10 EDT, Bryan Mason
no flags Details | Diff

  None (edit)
Description Bryan Mason 2006-10-11 14:10:22 EDT
From 
http://wiki.dovecot.org/Migration#head-43592855f2f429c6506547eba969436eff3f6e18:

By default Dovecot generates POP3 UIDs differently than UW-IMAP, which causes
POP3 clients to not recognize them and redownload messages they had downloaded
previously.

If you want Dovecot to use the same UID format as UW-IMAP/ipop3d so that clients
can recognize them, your required action depends on the Dovecot version.

Dovecot 0.99.X

    With Dovecot 0.99.x you'll have to patch Dovecot[1]

[1]http://dovecot.org/patches/old/pop3-uidl-uwimap.patch

Patch referenced in [1] is attached to this BZ.
Comment 1 Bryan Mason 2006-10-11 14:10:22 EDT
Created attachment 138264 [details]
Patch to address issues with dovecot migration from IMAP to POP3.  From http://dovecot.org/patches/old/pop3-uidl-uwimap.patch.
Comment 2 Petr Rockai 2006-10-11 14:37:39 EDT

*** This bug has been marked as a duplicate of 210246 ***

Note You need to log in before you can comment on or make changes to this bug.