Bug 210380 - radeon hangs DMA when CONFIG_CALGARY_IOMMU is build in kernel.
radeon hangs DMA when CONFIG_CALGARY_IOMMU is build in kernel.
Status: CLOSED DUPLICATE of bug 197992
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Konrad Rzeszutek
Brian Brock
:
Depends On: 203971
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-11 15:19 EDT by Konrad Rzeszutek
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 13:16:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konrad Rzeszutek 2006-10-11 15:19:19 EDT
Description of problem:
Having Calgary IOMMU enabled hangs X.

Version-Release number of selected component (if applicable):


How reproducible:
Install 2.6.18-1.2717 or later with X.

Steps to Reproduce:
1. Turn on machine and see it hang
  
Actual results:

Hang
Expected results:
Not hang

Additional info:
Comment 1 Konrad Rzeszutek 2006-10-11 15:27:43 EDT
Fix is to fix the radeon and the kernel to work nicely together. That is not
going to happend for RHEL5.

The workaround is to pass 'iommu=soft' or disable in the build
CONFIG_CALGARY_IOMMU as so:
[root@ibm-x232 SOURCES]grep "CALGARY" kernel-2.6.18-*
kernel-2.6.18-x86_64.config:# CONFIG_CALGARY_IOMMU is not set
kernel-2.6.18-x86_64-kdump.config:# CONFIG_CALGARY_IOMMU is not set
kernel-2.6.18-x86_64-xen.config:CONFIG_CALGARY_IOMMU=y

The fix is as follow:

--- kernel-2.6.18-x86_64.config.orig    2006-10-05 15:33:57.000000000 -0400
+++ kernel-2.6.18-x86_64.config 2006-10-11 13:48:31.000000000 -0400
@@ -2903,7 +2903,7 @@
 CONFIG_DEBUG_RODATA=y
 CONFIG_MICROCODE=m
 CONFIG_SWIOTLB=y
-CONFIG_CALGARY_IOMMU=y
+# CONFIG_CALGARY_IOMMU is not set
 CONFIG_X86_PM_TIMER=y
 CONFIG_EDD=m
 CONFIG_PCI_BIOS=y
--- kernel-2.6.18-x86_64-kdump.config.orig      2006-10-05 15:33:57.000000000 -0400
+++ kernel-2.6.18-x86_64-kdump.config   2006-10-11 13:48:42.000000000 -0400
@@ -2903,7 +2903,7 @@
 CONFIG_DEBUG_RODATA=y
 CONFIG_MICROCODE=m
 CONFIG_SWIOTLB=y
-CONFIG_CALGARY_IOMMU=y
+# CONFIG_CALGARY_IOMMU is not set
 CONFIG_X86_PM_TIMER=y
 CONFIG_EDD=m
 CONFIG_PCI_BIOS=y
Comment 2 Konrad Rzeszutek 2006-10-11 16:01:02 EDT
Patch posted for inclusion in RHEL5.
Comment 3 RHEL Product and Program Management 2006-10-11 16:18:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 4 Don Zickus 2006-10-11 18:39:47 EDT
in kernel-2.6.18-1.2726.el5
Comment 5 Jay Turner 2006-10-12 11:25:35 EDT
QE ack for RHEL5B2 according to section 21a of the release criteria.
Comment 6 Konrad Rzeszutek 2006-10-16 13:15:23 EDT
I have to NACK my patch. The new radeon driver
(xorg-x11-drv-ati-6.6.2-4.1.el5.src.rpm) fixes this problem without disabling
CALGARY_IOMMU.
Comment 7 Konrad Rzeszutek 2006-10-16 13:16:27 EDT
Fix is in RH BZ #197992

*** This bug has been marked as a duplicate of 197992 ***

Note You need to log in before you can comment on or make changes to this bug.