Bug 210398 - converted mirrors need the rename function as well
converted mirrors need the rename function as well
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Earl Brassow
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-11 16:40 EDT by Corey Marthaler
Modified: 2007-11-16 20:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 16:25:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2006-10-11 16:40:30 EDT
Description of problem:
RHEL4u4 version of bz 210396

You can rename a "regular" mirror but not a converted mirror.

# Works
[root@link-08 lvm]# lvcreate -n mirror -L 10G vg
  Logical volume "mirror" created
[root@link-08 lvm]# lvrename vg /dev/vg/mirror mirror2
  Renamed "mirror" to "mirror2" in volume group "vg"


# Doesn't work
[root@link-08 lvm]# lvcreate -L 10G -n lv vg
  Logical volume "lv" created
[root@link-08 lvm]# lvconvert -m 1 /dev/vg/lv
  Logical volume lv converted.
[root@link-08 lvm]# lvrename vg /dev/vg/lv mirror2
  Mirrored LV, "lv" cannot be renamed: Function not implemented

Version-Release number of selected component (if applicable):
[root@link-08 lvm]# rpm -q lvm2
lvm2-2.02.06-6.0.RHEL4
Comment 1 Jonathan Earl Brassow 2006-11-30 15:56:06 EST
Mirrors should not be able to be renamed, no matter how they are created.  I
believe there is an RFE for this though.

[root@neo-06 ~]# lvcreate -m1 -L 500M -n lv vg
  Logical volume "lv" created
[root@neo-06 ~]# lvrename vg lv lv2
  Mirrored LV, "lv" cannot be renamed: Function not implemented
[root@neo-06 ~]# lvrename vg /dev/vg/lv lv2
  Mirrored LV, "lv" cannot be renamed: Function not implemented
Comment 2 Corey Marthaler 2006-12-11 16:25:22 EST
Jon you're correct. This is not a bug.

Note You need to log in before you can comment on or make changes to this bug.