Bug 210429 - Aixgl patches break xorg
Aixgl patches break xorg
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
5
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-11 20:01 EDT by Samareanu Florin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-12 14:42:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.conf file (3.27 KB, application/octet-stream)
2006-10-11 20:01 EDT, Samareanu Florin
no flags Details

  None (edit)
Description Samareanu Florin 2006-10-11 20:01:42 EDT
Description of problem:

After installing the rpm`s as stated here:
http://fedoraproject.org/wiki/RenderingProject/AiglxOnFedora

my Dell 505 gives me corrupt image and the mouse is missing. The image show
garbage and visual artefacts on the upper side of the screen.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-0:1.1.1-17.fc5.aiglx
xorg-x11-server-Xorg-1.0.1-9.fc5.5

How reproducible:

update the xorg-x11-server to the aixgl version


Steps to Reproduce:

1. Fedora Core clean install, install 855 resolution to get 1400x1050, update
the system
2.enable the aixgl repository with yum --enablerepo=aiglx update
3. restart gdm
  
Actual results:

Corrupt image

Expected results:

Aixgl?

Additional info:
Comment 1 Samareanu Florin 2006-10-11 20:01:42 EDT
Created attachment 138293 [details]
Xorg.conf file
Comment 2 Samareanu Florin 2006-10-12 09:52:01 EDT
after upgrading to fedora core 6 test3 the problem is even bigger: with the
options in xorg.conf unchanged the bug persists.


[root@Raziel yum.repos.d]# rpm -qa |grep xorg-x11-server
xorg-x11-server-utils-7.1-4.fc6
xorg-x11-server-Xgl-1.1.99.1-3
xorg-x11-server-Xorg-1.1.1-47.fc6

this is what i have installed at the moment.

The fix for the problem is setting SWCursor and NOAccel in xorg.conf, but i have
lost DRI.
Comment 3 Kristian Høgsberg 2006-10-12 14:42:37 EDT
Please consider updgrading to Fedora Core 6 which will be out in a few days if
you're looking to run compiz or use aiglx.  If the problem persist with these
packages please file a new bug.

Thanks,
Kristian
Comment 4 Samareanu Florin 2006-10-12 16:10:45 EDT
Thank you for your response. 
As i have already told you, i`ve updated to the test3 release that is available
for FC6. I`ll wait for the final release and add a follow-up. 

Note You need to log in before you can comment on or make changes to this bug.