Bug 210433 - glibc-2.5-3 build fails
glibc-2.5-3 build fails
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
sparcv9 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-11 21:07 EDT by Dennis Gilmore
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-13 17:13:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glibc-2.5-3 build log (370.55 KB, text/plain)
2006-10-11 21:07 EDT, Dennis Gilmore
no flags Details
output of readelf -Wa build*sparc*nptl/elf/ld.so (68.09 KB, text/plain)
2006-10-12 23:37 EDT, Dennis Gilmore
no flags Details

  None (edit)
Description Dennis Gilmore 2006-10-11 21:07:11 EDT
Description of problem:
glibc-2.5-3 fails to build on sparc arches

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dennis Gilmore 2006-10-11 21:07:13 EDT
Created attachment 138295 [details]
glibc-2.5-3  build log
Comment 2 Jakub Jelinek 2006-10-12 10:27:15 EDT
What does readelf -Wa build*sparc*nptl/elf/ld.so print?
Comment 3 Dennis Gilmore 2006-10-12 23:37:07 EDT
Created attachment 138399 [details]
output of readelf -Wa build*sparc*nptl/elf/ld.so

requested info
Comment 4 Dennis Gilmore 2006-10-12 23:38:32 EDT
Please let me know if you need anything else
Comment 5 Jakub Jelinek 2006-10-13 17:13:31 EDT
You need to fix your binutils.
http://sources.redhat.com/ml/binutils/2006-10/msg00101.html
fix has been committed to CVS trunk, or you can apply it as a patch against
your binutils before rebuilding glibc.
Comment 6 Dennis Gilmore 2006-10-13 18:34:57 EDT
thanks for the info.  looks like it corrected debuginfo creation also. I havnt  
built a  new glibc  yet  but i have rebuilt binutils and elfutils.  glibc  is 
about to start 

Note You need to log in before you can comment on or make changes to this bug.