Bug 210456 - Click some search results in yelp: Could not load document
Click some search results in yelp: Could not load document
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-12 05:02 EDT by Xiaohong Wang
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-23 23:26:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (93.40 KB, image/png)
2006-10-12 05:02 EDT, Xiaohong Wang
no flags Details
handle location of posix man pages (600 bytes, patch)
2007-04-18 13:36 EDT, Matthias Clasen
no flags Details | Diff
handle cross references a bit better (2.58 KB, patch)
2007-04-18 13:37 EDT, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Xiaohong Wang 2006-10-12 05:02:41 EDT
Description of problem:


Version-Release number of selected component (if applicable):
yelp-2.16.0-3.fc6

How reproducible:
always

Steps to Reproduce:
1. launch yelp 
2. Search "metacity"
3. click link "metacity manual page"
  
Actual results:
An error dialog pops up 
-------------------------------
Could not load document

The Uniform Resource Identifier 'man:metacity(rpm)'
is invalid or does not point to an actual file.
-------------------------------

Expected results:
link to relevant help topic

Additional info:
Comment 1 Xiaohong Wang 2006-10-12 05:02:41 EDT
Created attachment 138313 [details]
screenshot
Comment 2 das_deniz 2006-10-13 12:27:04 EDT
i'm also seeing this

it seems to be related to 'man' page links with '[something]' in the hyperlinked
text. 

take the following for example:

Search results for "yum"

Fedora Core Release Notes
    yum
yum manual page
    Yellowdog Updater Modified
yum [yum-shell] manual page
    Yellowdog Updater Modified shell
yum-updatesd manual page
    Update notifier daemon
yum-updatesd.conf [yum-updatesd] manual page
    Configuration file for yum-updatesd(8)
yum.conf [yum] manual page
    Configuration file for yum(8)

all the man page results work *EXCEPT* for these 
yum [yum-shell] manual page
yum-updatesd.conf [yum-updatesd] manual page
yum.conf [yum] manual page

and the fail-dialogue reports:

The Uniform Resource Identifier ‘man:yum [yum-shell](8)’ is invalid or does not
point to an actual file.
Comment 3 das_deniz 2006-10-13 13:11:37 EDT
btw - i do not see this with metacity as an example with these versions

  man-1.6d-1.1
  man-pages-2.39-5
  yelp-2.16.0-4.fc6
  metacity-2.16.0-5.fc6

so for these man related instances it seems that yelp is trying to do the right
thing but that the output from 'man -f yum' is inconsistent....

yum                  (8)  - Yellowdog Updater Modified
yum [yum-shell]      (8)  - Yellowdog Updater Modified shell
yum-updatesd         (8)  - Update notifier daemon
yum-updatesd.conf [yum-updatesd] (5)  - Configuration file for yum-updatesd(8)
yum.conf [yum]       (5)  - Configuration file for yum(8)

man 8 yum-shell          - works
man 5 yum-updatesd       - does not work
man 5 yum-updatesd.conf  - works

so you can't just s/[<blah>]// it away or use only what's enclosed and the page
instead....

even with this flawed interface i'm delighted to see the inclusion of man in
yelp again - thanks for this wonderful helpful browser.
Comment 4 Christopher Aillon 2007-04-17 15:35:00 EDT
is this an issue in rawhide still?
Comment 5 das_deniz 2007-04-17 16:49:12 EDT
as of Apr 17th 16:30 EDT... f7t3 + updates

man-pages-2.44-1.fc7.noarch
man-1.6e-3.fc7.x86_64
yelp-2.18.1-2.fc7.x86_64

it seems better initially - after /usr/sbin/makewhatis and comparing man -f yum
and yelp 'yum' search results and links - things were looking pretty good.

but a similar yelp search on 'pthread' and trying the "pthread_atfork" manual
page we get the familar dialog:

  The Uniform Resource Identifier ‘man:pthread_atfork(3p)’ is invalid or does
not point to an actual file.

also, many of the the "SEE ALSO" items are not hyper/marked-up for example
ManuapPages -> Applications -> NetworkManager has non-hyperlinked SEE ALSO
references to "NetworkManagerDispatcher(1),nm-tool(1)".
Comment 6 Matthias Clasen 2007-04-18 13:36:37 EDT
Created attachment 152929 [details]
handle location of posix man pages
Comment 7 Matthias Clasen 2007-04-18 13:37:30 EDT
Created attachment 152930 [details]
handle cross references a bit better
Comment 8 Matthias Clasen 2007-04-18 13:43:16 EDT
I've filed upstream bugs for these patches: 

http://bugzilla.gnome.org/show_bug.cgi?id=431077
http://bugzilla.gnome.org/show_bug.cgi?id=431078
Comment 9 Matthias Clasen 2007-04-23 23:26:50 EDT
These patches are also in the rawhide package now.
Comment 10 das_deniz 2007-04-24 08:15:08 EDT
what's been made available for fedora 7 devel as of 8:00am EDT Tues Apr 24th:

yelp-2.18.1-2.fc7.x86_64
man-1.6e-3.fc7.x86_64

does not behave any differently than reported in Comment #5 above.

to save answering comments like this in the future (assuming i am not testing
the right version) you should report the version of the pkg with the fix....

Note You need to log in before you can comment on or make changes to this bug.