Bug 210472 - ia64 EFI memory map not included in the kdump vmcore
ia64 EFI memory map not included in the kdump vmcore
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks: 212846
  Show dependency treegraph
 
Reported: 2006-10-12 09:18 EDT by Dave Anderson
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 16:20:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
http://lists.osdl.org/pipermail/fastboot/2006-August/003677.html (2.28 KB, text/plain)
2006-10-12 09:28 EDT, Dave Anderson
no flags Details
http://lists.osdl.org/pipermail/fastboot/2006-August/003678.html (7.69 KB, text/plain)
2006-10-12 09:29 EDT, Dave Anderson
no flags Details

  None (edit)
Description Dave Anderson 2006-10-12 09:18:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030611

Description of problem:

The system's EFI memory map is not included in an ia64 kdump vmcore.

This is evidenced by running the crash utility against it, where
the following warning message is displayed during initialization:

  WARNING: EFI memory verification will not be performed

Also, if during the crash session the "mach -m" command is attempted,
it will fail like so:

  crash> mach -m
  mach: efi_mmap not accessible



Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. run crash utility on ia64 kdump vmcore
2. run "mach -m" during crash session
3.

Actual Results:
Note "WARNING: EFI memory verification will not be performed" during
invocation.  

During session, "mach -m" command fails with: "mach: efi_mmap not accessible"

Expected Results:
No initialization-time WARNING should be displayed, and the "mach -m"
command should dump the contents of the EFI memory map.



Additional info:

The reason that this occurs is because the system's EFI memory map
is not being copied to the kdump vmcore.  This issue has been addressed
in these fastboot mailing list patches from nanhai.zou@intel.com:

  http://lists.osdl.org/pipermail/fastboot/2006-August/003677.html
  http://lists.osdl.org/pipermail/fastboot/2006-August/003678.html

When asked on 10/12/06 whether the patches above are still valid,
Zou Nan hai replied: 

> Yes, please include the 2 patches.
> The first patch is to fix Kexec from a Kexeced kernel issue.
> The second patch will fix the EFI memmap not included issue.
>
> Thanks 
> Zou Nan hai
Comment 3 Dave Anderson 2006-10-12 09:31:12 EDT
Verified that the attached patches apply cleanly to kexec-tools-1.101-91.el5.
Comment 4 Neil Horman 2006-10-12 14:56:35 EDT
added to -94.el5.  Thanks Dave!
Comment 6 RHEL Product and Program Management 2006-10-31 08:45:17 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 8 Jay Turner 2006-10-31 14:53:37 EST
QE ack for RHEL5B2.

Note You need to log in before you can comment on or make changes to this bug.