Bug 21048 - Crashed man.
Summary: Crashed man.
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-18 13:26 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-18 13:26:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-11-18 13:26:23 UTC
Crashed man.

[alz27@psylab alz27]$ man zcat
Segmentation fault

(limit core has size=0)

(gdb) run
Starting program: /usr/bin/man zcat

Program received signal SIGSEGV, Segmentation fault.
0x4002f434 in __open_catalog (catalog=0x8062950, with_path=1)
    at open_catalog.c:91
open_catalog.c:91: No such file or directory.
(gdb) print catalog
$1 = (struct catalog_info *) 0x8062950
(gdb) x/s catalog
0x8062950 <optind+72856>:        ""
(gdb) bt
#0  0x4002f434 in __open_catalog (catalog=0x8062950, with_path=1)
    at open_catalog.c:91
#1  0x4002f157 in catgets (catalog_desc=0x8062950, set=2, message=40, 
    string=0x804e983 "") at catgets.c:137
#2  0x804d584 in _start ()
#3  0x804d5e0 in _start ()
#4  0x804a1c2 in _start ()
#5  0x804a43b in _start ()
#6  0x804a540 in _start ()
#7  0x804a859 in _start ()
#8  0x804b087 in _start ()



strace man zcat
chmod("/var/catman/cat1/zcat.1.gz", 0666) = 0
ioctl(0, TCGETS, {B9600 opost isig icanon echo ...}) = 0
ioctl(1, TCGETS, {B9600 opost isig icanon echo ...}) = 0
open("/usr/man/man1/zcat.1", O_RDONLY)  = 4
fstat(4, {st_mode=0, st_size=0, ...})   = 0
mmap(0, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x4000c000
read(4, ".PU\n.TH GZIP 1 local\n.SH NAME\n"..., 4096) = 4096
close(4)                                = 0
munmap(0x4000c000, 4096)                = 0
sigaction(SIGINT, {SIG_IGN}, {SIG_DFL}) = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++

Comment 1 Bernhard Rosenkraenzer 2000-11-18 20:18:27 UTC
I can't reproduce this. Make sure you're using the current version of man (from updates).

Comment 2 Need Real Name 2000-11-20 07:49:40 UTC
[alz27@psylab alz27]$ rpm -q man
man-1.5h1-2.5.x

This last version ?

[alz27@psylab alz27]$ rpm -q glibc
glibc-2.0.7-29.2

This began after updated glibc to this version.



Note You need to log in before you can comment on or make changes to this bug.