Bug 210519 - Fix for numpy-1.0rc2
Summary: Fix for numpy-1.0rc2
Status: CLOSED DUPLICATE of bug 212147
Alias: None
Product: Fedora
Classification: Fedora
Component: numpy   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-12 17:58 UTC by Neal Becker
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-25 18:23:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec (3.13 KB, text/plain)
2006-10-12 17:58 UTC, Neal Becker
no flags Details
spec (3.31 KB, text/plain)
2006-10-25 21:00 UTC, Neal Becker
no flags Details

Description Neal Becker 2006-10-12 17:58:45 UTC
Description of problem:

Looks like this spec file works.
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Neal Becker 2006-10-12 17:58:45 UTC
Created attachment 138350 [details]
spec

Comment 2 Jarod Wilson 2006-10-25 18:22:33 UTC
How exactly did you get around this issue:

http://projects.scipy.org/pipermail/scipy-dev/2006-August/006070.html

I'm seeing the same thing with a 1.0 release build...

Comment 3 Jarod Wilson 2006-10-25 18:23:50 UTC

*** This bug has been marked as a duplicate of 212147 ***

Comment 4 Neal Becker 2006-10-25 18:59:00 UTC
(In reply to comment #2)
> How exactly did you get around this issue:
> 
> http://projects.scipy.org/pipermail/scipy-dev/2006-August/006070.html
> 
> I'm seeing the same thing with a 1.0 release build...

I don't recall, and I'm busy now - please try my spec and see if that answers 
the question

Comment 5 Jarod Wilson 2006-10-25 19:08:53 UTC
Nope, same thing happens with both my spec and your spec.

Comment 6 Neal Becker 2006-10-25 21:00:21 UTC
Created attachment 139408 [details]
spec

Try this.  IIRC, it seems that the original separation of build/install is
broken.  If build goes ahead and does install, then the problem isn't there.

Comment 7 Jarod Wilson 2006-10-25 21:53:52 UTC
Hrm, okay, that does work. Looks like specifically, the --skip-build option is
busted. Omitting that and adding in all the assorted flags from %build under
%install works around this and feels less dirty than doing the install in
%build. I'll go ahead and push this into rawhide for now.

-- spec snippet --

%build
ATLAS=%{_libdir} FFTW=%{_libdir} BLAS=%{_libdir} \
    LAPACK=%{_libdir} CFLAGS="$RPM_OPT_FLAGS" \
    %{__python} setup.py build

%install
rm -rf $RPM_BUILD_ROOT
#%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
# skip-build currently broken, this works around it for now
ATLAS=%{_libdir} FFTW=%{_libdir} BLAS=%{_libdir} \
    LAPACK=%{_libdir} CFLAGS="$RPM_OPT_FLAGS" \
    %{__python} setup.py install --root $RPM_BUILD_ROOT


Note You need to log in before you can comment on or make changes to this bug.