Bug 210551 - Screen should be included in the default/base install
Screen should be included in the default/base install
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-12 16:18 EDT by Robin Norwood
Modified: 2014-03-16 23:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 12:20:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Norwood 2006-10-12 16:18:18 EDT
'screen' is an oft-used utility, especially when logging in remotely - it's been
around for years, it's part of gnu, and it isn't undergoing a lot of active
development.

The general scenario I run into is that I log in remotely to a system that
someone (perhaps me) has installed - I want to do 'a bunch of stuff', including
perhaps long-running processes.  Without screen, if I get disconnected, I have
to spend some time recovering my terminals, and dealing with long-running
processes that lost their terminal when I was disconnected.  With screen, I can
just reconnect and use screen -r to get back to where I was.  Unfortunately,
since screen isn't in the default install, it isn't usually on the box unless
someone thoughtfully installed it.

If I have root on the box, I can install screen myself - but if I don't, I'm out
of luck in these situations.
Comment 1 Dennis Gregorovic 2006-10-12 16:38:35 EDT
Daniel, it's your call.
Comment 2 Dennis Gregorovic 2006-10-12 16:39:17 EDT
Sorry, I was confused.
Comment 3 Jesse Keating 2006-12-15 12:20:51 EST
we're changing how the distribution is put together.  Lots of input/discussion
will happen most likely on fedora-devel leading up to the first test release of
F7.  I'm closing this bug as discussion should happen there.

Note You need to log in before you can comment on or make changes to this bug.