Bug 210580 - Blender has many display artifacts with desktop effects on
Blender has many display artifacts with desktop effects on
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: blender (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-12 18:14 EDT by Brian G. Anderson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 12:40:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
desktop bar artifacts at the top (144.29 KB, image/png)
2006-10-12 18:14 EDT, Brian G. Anderson
no flags Details
this is after the printscreen dialog box was removed (402.22 KB, image/png)
2006-10-12 18:17 EDT, Brian G. Anderson
no flags Details
blender bombs out and screen isn't cleaned up (152.85 KB, image/png)
2006-10-12 18:20 EDT, Brian G. Anderson
no flags Details

  None (edit)
Description Brian G. Anderson 2006-10-12 18:14:35 EDT
Description of problem:
If I turn on desktop effects on my IBM T42p with an ATI Fire GL Mobility T2 [M10
 NT], then blender starts getting strange artifacts on the screen.  These include:
* going to the top of the screen starts showing the desktop bar even though
blender is full screen.  With desktop effects off then the bar at the top is hidden.
* any terminal behind blender will suddenly appear when any new output appears.
 Mousing over the terminal will start to show blender again.
* any pop up dialog will leave the desktop when it disappears instead of the
blender.
* when I try and render the scene, blender exits with a "Could not get dma
buffer" error.  This doesn't happen when I don't have desktop effects on.

Much of this is better understood if you look at the screen shots I've attached.


Version-Release number of selected component (if applicable):
blender.i386                             2.42a-2.fc6              installed
xorg-x11-drv-ati.i386                    6.6.2-4.fc6              installed



How reproducible:
always


Steps to Reproduce:
1.turn on desktop effects
2.run blender
3.
  
Actual results:
strange rendering artifacts

Expected results:


Additional info:
Comment 1 Brian G. Anderson 2006-10-12 18:14:37 EDT
Created attachment 138390 [details]
desktop bar artifacts at the top
Comment 2 Brian G. Anderson 2006-10-12 18:17:22 EDT
Created attachment 138391 [details]
this is after the printscreen dialog box was removed

notice how the desktop background shows through
Comment 3 Brian G. Anderson 2006-10-12 18:20:38 EDT
Created attachment 138392 [details]
blender bombs out and screen isn't cleaned up

Notice the "Could not get dma buffer...exiting" message as well as the r300
driver error messages.
Comment 4 Jochen Schmitt 2007-02-06 11:53:49 EST
do you use compiz?

I'm using beryl. Before I have installed the most recent version of beryl, I
have recorgnized strange artefacts on blender and stellarium.

After I have installed the lastest version of beryl available on Fedora Extras,
I don't have any problem with this appplications.

So I want, that you should to the following things:

1.) Update to the most recent version of beryl.
2.) If you will got the complaints artefacts anymore, you should disable
compiz/beryl.
Comment 5 Brian G. Anderson 2007-02-06 12:57:25 EST
I've used both compiz and beryl.  Even on the latest releases it has problems
with artifacts and missing borders.  I believe it is a driver problem since I
don't have these problems on my desktop under beryl using an nVidia driver.

Note You need to log in before you can comment on or make changes to this bug.