Bug 210581 - up2date Fails to update GFS kernel packages and supporting applications.
up2date Fails to update GFS kernel packages and supporting applications.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: GFS-kernel (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Chris Feist
Dean Jansa
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-12 18:16 EDT by Anand
Modified: 2010-01-11 22:23 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:24:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand 2006-10-12 18:16:18 EDT
Description of problem:

up2date fails to install GFS and RHEL Cluster related rpms. The up2date prgoram
exits saying it cannot resolve the dependency list. 

Version-Release number of selected component (if applicable):


How reproducible:

up2date -u 
(make sure you have GFS and Cluster enabled in the channel selection tab)
Steps to Reproduce:
1.run up2date -u 
2.
3.
  
Actual results:

################################################################################
 up2date -u

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching Obsoletes list for channel: rhel-i386-as-4-extras...

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-i386...

Fetching Obsoletes list for channel: rhel-i386-as-4-gfs-6.1...

Fetching Obsoletes list for channel: rhel-i386-as-4-cluster...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
GFS-kernel                              2.6.9          60.1              i686
GFS-kernel-hugemem                      2.6.9          60.1              i686
GFS-kernel-smp                          2.6.9          60.1              i686
GFS-kernheaders                         2.6.9          60.1              i686
cman-kernel                             2.6.9          45.5              i686
cman-kernel-hugemem                     2.6.9          45.5              i686
cman-kernel-smp                         2.6.9          45.5              i686
cman-kernheaders                        2.6.9          45.5              i686
dlm-kernel                              2.6.9          44.2              i686
dlm-kernel-hugemem                      2.6.9          44.2              i686
dlm-kernel-smp                          2.6.9          44.2              i686
dlm-kernheaders                         2.6.9          44.2              i686
gnbd                                    1.0.8          0                 i686
gnbd-kernel                             2.6.9          9.44              i686
gnbd-kernel-hugemem                     2.6.9          9.44              i686
gnbd-kernel-smp                         2.6.9          9.44              i686
gnbd-kernheaders                        2.6.9          9.44              i686
gnutls                                  1.0.20         3.2.3             i386
gulm                                    1.0.8          0                 i686
gulm-devel                              1.0.8          0                 i686
gzip                                    1.3.3          16.rhel4          i386
hwdata                                  0.146.23.EL    1                 noarch
openssh                                 3.9p1          8.RHEL4.17        i386
openssh-clients                         3.9p1          8.RHEL4.17        i386
openssh-server                          3.9p1          8.RHEL4.17        i386
openssl                                 0.9.7a         43.14             i686
openssl096b                             0.9.6b         22.46             i386
php                                     4.3.9          3.18              i386
php-pear                                4.3.9          3.18              i386
python                                  2.3.4          14.3              i386
rgmanager                               1.9.54         1                 i386
seamonkey-nspr                          1.0.5          0.1.el4           i386
seamonkey-nss                           1.0.5          0.1.el4           i386
xorg-x11                                6.8.2          1.EL.13.37.2      i386
xorg-x11-Mesa-libGL                     6.8.2          1.EL.13.37.2      i386
xorg-x11-Mesa-libGLU                    6.8.2          1.EL.13.37.2      i386
xorg-x11-deprecated-libs                6.8.2          1.EL.13.37.2      i386
xorg-x11-font-utils                     6.8.2          1.EL.13.37.2      i386
xorg-x11-libs                           6.8.2          1.EL.13.37.2      i386
xorg-x11-xauth                          6.8.2          1.EL.13.37.2      i386
xorg-x11-xdm                            6.8.2          1.EL.13.37.2      i386
xorg-x11-xfs                            6.8.2          1.EL.13.37.2      i386


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

    To solve all dependencies for the RPMs you have selected, The following
    packages you have marked to exclude would have to be added to the set:

    Package Name                        Reason For Skipping
    ======================================================================
    kernel-2.6.9-42.0.3.EL              Pkg name/pattern
    kernel-devel-2.6.9-42.0.3.EL        Pkg name/pattern
    kernel-doc-2.6.9-42.0.3.EL          Pkg name/pattern
    kernel-hugemem-2.6.9-42.0.3.EL      Pkg name/pattern
    kernel-hugemem-devel-2.6.9-42.      Pkg name/pattern
    kernel-ib-1.0-1                     Pkg name/pattern
    kernel-smp-2.6.9-42.0.3.EL          Pkg name/pattern
    kernel-smp-devel-2.6.9-42.0.3.      Pkg name/pattern
    kernel-utils-2.4-13.1.83            Pkg name/pattern

Unresolvable chain of dependencies:
GFS-kernel  2.6.9-60.1                   requires /lib/modules/2.6.9-42.0.2.EL
GFS-kernel-hugemem  2.6.9-60.1           requires
/lib/modules/2.6.9-42.0.2.ELhugemem
GFS-kernel-hugemem-2.6.9-60.1            requires kernel-hugemem = 2.6.9-42.0.2.EL
GFS-kernel-smp  2.6.9-60.1               requires /lib/modules/2.6.9-42.0.2.ELsmp
GFS-kernel-smp-2.6.9-60.1                requires kernel-smp = 2.6.9-42.0.2.EL
cman-kernel  2.6.9-45.5                  requires /lib/modules/2.6.9-42.0.2.EL
cman-kernel-hugemem  2.6.9-45.5          requires
/lib/modules/2.6.9-42.0.2.ELhugemem
cman-kernel-hugemem-2.6.9-45.5           requires kernel-hugemem = 2.6.9-42.0.2.EL
cman-kernel-smp  2.6.9-45.5              requires /lib/modules/2.6.9-42.0.2.ELsmp
cman-kernel-smp-2.6.9-45.5               requires kernel-smp = 2.6.9-42.0.2.EL
dlm-kernel  2.6.9-44.2                   requires /lib/modules/2.6.9-42.0.2.EL
dlm-kernel-hugemem  2.6.9-44.2           requires
/lib/modules/2.6.9-42.0.2.ELhugemem
dlm-kernel-hugemem-2.6.9-44.2            requires kernel-hugemem = 2.6.9-42.0.2.EL
dlm-kernel-smp  2.6.9-44.2               requires /lib/modules/2.6.9-42.0.2.ELsmp
dlm-kernel-smp-2.6.9-44.2                requires kernel-smp = 2.6.9-42.0.2.EL
gnbd-kernel  2.6.9-9.44                  requires /lib/modules/2.6.9-42.0.2.EL
gnbd-kernel-hugemem  2.6.9-9.44          requires
/lib/modules/2.6.9-42.0.2.ELhugemem
gnbd-kernel-hugemem-2.6.9-9.44           requires kernel-hugemem = 2.6.9-42.0.2.EL
gnbd-kernel-smp  2.6.9-9.44              requires /lib/modules/2.6.9-42.0.2.ELsmp
gnbd-kernel-smp-2.6.9-9.44               requires kernel-smp = 2.6.9-42.0.2.EL


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------

################################################################################
Expected results:

It should install all the packages. 
Additional info: Not an isoalted cases happens to all machines on my cluster and
I am using the up2date servers https://xmlrpc.rhn.redhat.com/XMLRPC and
http://xmlrpc.rhn.redhat.com/XMLRPC.

Is there a work around for this problem.
Comment 1 Kiersten (Kerri) Anderson 2006-10-12 18:20:41 EDT
Releases for the 42.0.3 kernel have not been completed as of yet.  Working
through the process, expect support for that kernel by October 19, 2006.
Comment 2 Chris Feist 2006-10-18 12:24:11 EDT
Packages were released to RHN and were available as of Oct. 17th, can you verify
that you can up2date your packages now?

Note You need to log in before you can comment on or make changes to this bug.