Bug 210624 - RFE: specify partitions by cylinders in parted
RFE: specify partitions by cylinders in parted
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: David Cantrell
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-13 08:59 EDT by W Agtail
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-11 14:33:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kickstart file (2.34 KB, application/octet-stream)
2006-10-13 08:59 EDT, W Agtail
no flags Details

  None (edit)
Description W Agtail 2006-10-13 08:59:50 EDT
Description of problem:
1st thing, anaconda fails with error message "Error opening /dev/sdc: No medium
found" during kickstart. runnning fdisk -l only shows sda & sdb, which is expected.

Anywayz, real problem is with reference to bug: 204181. See attached ks.cfg file.

parted doesn't partition the disks correctly.
fdisk -l reports:
Partition 2 does not end on cylinder boundary.
Partition 3 does not end on cylinder boundary.

Could we fix this so that start cyl starts on a unused cyl?
Also, could we have the option to use start & end cyls with parted in kickstart?
e.g: at present you can use something like:
parted -s /dev/sda mkpart primary 4608 6656
which is start & end in MB.
could we have something like:
parted -s /dev/sda mkpart primary 4608m 6656m
and
parted -s /dev/sda mkpart primary 16c 100c
or what ever is appropiate please?

Version-Release number of selected component (if applicable):
DVD ISO Test 3

How reproducible:
always


Steps to Reproduce:
kickstart with attached ks.cfg file
2.
3.
  
Actual results:
as mentioned above, fdisk -l, displays errors due to cylinder boundaries.

Expected results:
a disk partitioned correctly

Additional info:
i'll try todays rawhide too
Comment 1 W Agtail 2006-10-13 08:59:52 EDT
Created attachment 138426 [details]
kickstart file
Comment 2 W Agtail 2006-10-13 09:15:26 EDT
FYI: anaconda doesn't moan about sdc with today's rawhide.
Comment 3 David Cantrell 2006-10-13 12:16:26 EDT
(In reply to comment #0)
> Description of problem:
> 1st thing, anaconda fails with error message "Error opening /dev/sdc: No medium
> found" during kickstart. runnning fdisk -l only shows sda & sdb, which is
expected.

This is anaconda bug, so file these against anaconda.

> Anywayz, real problem is with reference to bug: 204181. See attached ks.cfg file.
> 
> parted doesn't partition the disks correctly.
> fdisk -l reports:
> Partition 2 does not end on cylinder boundary.
> Partition 3 does not end on cylinder boundary.
> 
> Could we fix this so that start cyl starts on a unused cyl?
> Also, could we have the option to use start & end cyls with parted in kickstart?
> e.g: at present you can use something like:
> parted -s /dev/sda mkpart primary 4608 6656
> which is start & end in MB.
> could we have something like:
> parted -s /dev/sda mkpart primary 4608m 6656m
> and
> parted -s /dev/sda mkpart primary 16c 100c
> or what ever is appropiate please?

As stated in bug #204181, parted does not currently allow users to specify
cylinders when creating partitions.  You can only specify sizes.  This is a
feature slated for an upcoming release of parted, but it's not there right now.
 It's going to require reworking the API a bit, but we have the idea tabled.

In the grand scheme of things, you should never care about cylinders.  This is
why parted doesn't support this feature right now.  The fdisk you may be using
could be incorrect as well.  Our plan with parted is to offer libparted-based
replacements for the aging fdisk in util-linux, which is not ideal for users.

You can try with GNU fdisk right now and see if it works for you:

http://www.gnu.org/software/fdisk/

GNU fdisk is under development right now, but we're close to a release point.
Comment 4 David Cantrell 2007-04-11 14:33:31 EDT
Parted allows you to specify starting and ending partition boundaries by
cylinder (among other units):

# parted /dev/sda
GNU Parted 1.8.6
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print                                                            
Model: ATA ST910021A (scsi)
Disk /dev/sda: 100GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size    Type     File system  Flags
 1      32.3kB  107MB  107MB   primary  ext3         boot 
 2      107MB   100GB  99.9GB  primary               lvm  

(parted) unit cyl                                                         
(parted) print                                                            
Model: ATA ST910021A (scsi)
Disk /dev/sda: 12161cyl
Sector size (logical/physical): 512B/512B
BIOS cylinder,head,sector geometry: 12161,255,63.  Each cylinder is 8225kB.
Partition Table: msdos

Number  Start  End       Size      Type     File system  Flags
 1      0cyl   12cyl     12cyl     primary  ext3         boot 
 2      13cyl  12160cyl  12148cyl  primary               lvm  

(parted) help unit                                                        
  unit UNIT                                set the default unit to UNIT

        UNIT is one of: s, B, kB, MB, GB, TB, compact, cyl, chs, %, kiB, MiB,
        GiB, TiB
(parted)

Closing as fixed in rawhide.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.