Bug 210630 - AttributeError of YumAvailablePackageSqlite by mock-0.6.5-1.fc6
AttributeError of YumAvailablePackageSqlite by mock-0.6.5-1.fc6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 210654 210662 210723 210746 210752 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-13 09:39 EDT by Mamoru TASAKA
Modified: 2014-01-21 17:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-15 20:13:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2006-10-13 09:39:39 EDT
Description of problem:
When I try to rebuild some srpm by mockbuild, I get:
AttributeError: YumAvailablePackageSqlite instance has no attribute 'returnEVR'.

The error is called when using mock, however, I suspect this is
due to yum 

Version-Release number of selected component (if applicable):
yum-3.0-5
mock-0.6.5-1.fc6

How reproducible:
100%

Steps to Reproduce:
1. try to rebuild some srpm by mockbuild
2.
3.
  
Actual results:
DEBUG: Executing /usr/sbin/mock-helper yum --installroot
/var/lib/mock/fedora-development-i386-core/root install buildsys-build
Traceback (most recent call last):
  File "/usr/libexec/mock-yum", line 12, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 102, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 359, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 134, in doCommand
    return base.installPkgs(extcmds)
  File "/usr/share/yum-cli/cli.py", line 594, in installPkgs
    pkglist.extend(self.bestPackagesFromList(toBeInstalled[name]))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 1649, in
bestPackagesFromList
    no = self._bestPackageFromList(noarch)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 1608, in
_bestPackageFromList
    bestlist = mysack.returnNewestByNameArch() # get rid of all lesser vers
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 563, in
returnNewestByNameArch
    if pkg.EVR > pkg2.EVR:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 330, in <lambda>
    EVR = property(fget=lambda self: self.returnEVR())
AttributeError: YumAvailablePackageSqlite instance has no attribute 'returnEVR'
Error performing yum command: /usr/sbin/mock-helper yum --installroot
/var/lib/mock/fedora-development-i386-core/root install buildsys-build
ending

Expected results:


Additional info:
yum-3.0-4 is okay with mock-0.6.5-1.fc6
Comment 1 Jeremy Katz 2006-10-15 20:13:04 EDT
Fixed in yum-3.0-6
Comment 2 Jeremy Katz 2006-10-15 20:13:15 EDT
*** Bug 210654 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2006-10-15 20:13:36 EDT
*** Bug 210662 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2006-10-15 20:13:54 EDT
*** Bug 210723 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2006-10-15 20:14:06 EDT
*** Bug 210746 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2006-10-15 20:14:10 EDT
*** Bug 210752 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.