Bug 210654 - yum/pirut repotrt no attribute 'returnEVR' exception
Summary: yum/pirut repotrt no attribute 'returnEVR' exception
Status: CLOSED DUPLICATE of bug 210630
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-13 15:45 UTC by das_deniz
Modified: 2014-01-21 22:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 00:13:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum python exception traceback (2.70 KB, text/plain)
2006-10-13 15:45 UTC, das_deniz
no flags Details
AttributeError: YumAvailablePackageSqlite instance has no attribute 'returnEVR' (3.96 KB, text/plain)
2006-10-14 06:53 UTC, MartinG
no flags Details

Description das_deniz 2006-10-13 15:45:07 UTC
USUAL WORKAROUND - yum clean all metadata - does not help !!

Description of problem:

yum/pirut repotrt no attribute 'returnEVR' exception

Version-Release number of selected component (if applicable):

yum-metadata-parser-1.0-8.fc6
yum-3.0-5
yumex-1.1.4-2.0.fc6
yum-updatesd-3.0-5
pirut-1.2.5-1

How reproducible:

happens with yum and yumex repeatedly.

Steps to Reproduce:
1. yum list yum

Actual results:

fails while reading repositories / updating metadata.

Expected results:

no exception

Additional info:

similar to Bug 195564

Comment 1 das_deniz 2006-10-13 15:45:09 UTC
Created attachment 138444 [details]
yum python exception traceback

Comment 2 MartinG 2006-10-14 06:52:40 UTC
I can canfirm this bug. I am running FC6 Pre, and get the error when trying to 
install "mesa-libGLw", as well as "yum list yum".

I reboot did not fix the problem.

Linux x1 2.6.18-1.2784.fc6 #1 SMP Thu Oct 12 18:49:59 EDT 2006 i686 i686 i386 
GNU/Linux

YUM: 3.0

Comment 3 MartinG 2006-10-14 06:53:25 UTC
Created attachment 138490 [details]
AttributeError: YumAvailablePackageSqlite instance has no attribute 'returnEVR'

Comment 4 MartinG 2006-10-15 17:06:09 UTC
This bug is fixed in yum-3.0-6. Thank you!

Comment 5 Jeremy Katz 2006-10-16 00:13:09 UTC

*** This bug has been marked as a duplicate of 210630 ***


Note You need to log in before you can comment on or make changes to this bug.