This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 210682 - fenced can get into state where it doesn't leave the cluster
fenced can get into state where it doesn't leave the cluster
Status: CLOSED DUPLICATE of bug 217449
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Teigland
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-13 15:00 EDT by Corey Marthaler
Modified: 2009-09-03 12:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-12 12:56:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2006-10-13 15:00:35 EDT
Description of problem:
This may be related to 210641 or related to other cman/dlm daemon start stop
issues that have been filed.

I been playing around with starting and stoping cman in loops on a four node
cluster and I always seem to get into a state were fenced won't die on one or
more of the machines in the cluster.

[root@taft-01 ~]# service cman stop
Stopping cluster:
   Stopping fencing... done
   Stopping cman... done
   Stopping ccsd... done
   Unmounting configfs... done
                                                           [  OK  ]

[root@taft-02 ~]# service cman stop
Stopping cluster:
   Stopping fencing... done
   Stopping cman... failed
/usr/sbin/cman_tool: Error leaving cluster: Device or resource busy
                                                           [FAILED]

[root@taft-03 ~]# service cman stop
Stopping cluster:
   Stopping fencing... done
   Stopping cman... done
   Stopping ccsd... done
   Unmounting configfs... done
                                                           [  OK  ]
[root@taft-04 ~]# service cman stop
Stopping cluster:
   Stopping fencing... done
   Stopping cman... done
   Stopping ccsd... done
   Unmounting configfs... done
                                                           [  OK  ]


[root@taft-02 ~]# pidof fenced
7035
[root@taft-02 ~]# fence_tool leave
[root@taft-02 ~]# echo $?
0
[root@taft-02 ~]# pidof fenced
7035
[root@taft-02 ~]# cman_tool services
type             level name     id       state
fence            0     default  00010003 none
[2]


Version-Release number of selected component (if applicable):
[root@taft-02 ~]# uname -ar
Linux taft-02 2.6.18-1.2714.el5 #1 SMP Mon Oct 2 17:11:34 EDT 2006 x86_64 x86_64
x86_64 GNU/Linux


How reproducible:
Often
Comment 1 David Teigland 2006-10-17 14:13:39 EDT
Next time this happens collect the following from each node:

group_tool -v
group_dool dump
group_tool dump fence
anything from /var/log/messages
Comment 2 David Teigland 2006-12-12 12:56:58 EST

*** This bug has been marked as a duplicate of 217449 ***
Comment 3 Nate Straz 2007-12-13 12:40:44 EST
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.

Note You need to log in before you can comment on or make changes to this bug.