Bug 210723 - traceback when clicking on List tab
traceback when clicking on List tab
Status: CLOSED DUPLICATE of bug 210630
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-13 17:51 EDT by Luke Macken
Modified: 2016-09-19 22:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-15 20:13:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2006-10-13 17:51:36 EDT
I get the following traceback when clicking on the 'List' tab using
pirut-1.2.5-1 and yum-3.0-5.

===================================================================

Component: Software Manager
Summary: TB4f1d2ecf packages.py:330:<lambda>:AttributeError:
YumAvailablePackageSqlite instance has no attribute 'returnEVR'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 105, in _pageSwitch
    self.pageMap[num]()
  File "/usr/sbin/pirut", line 240, in _showListReal
    s = self.pkgSack.returnNewestByNameArch()
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 287, in
returnNewestByNameArch
   
bestofeach.addList(self._computeAggregateListResult("returnNewestByNameArch",
naTup))
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 323, in
_computeAggregateListResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 465, in
returnNewestByNameArch
    return yumRepo.YumPackageSack.returnNewestByNameArch(self, naTup)
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 563, in
returnNewestByNameArch
    if pkg.EVR > pkg2.EVR:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 330, in <lambda>
    EVR = property(fget=lambda self: self.returnEVR())
AttributeError: YumAvailablePackageSqlite instance has no attribute 'returnEVR'

Local variables in innermost frame:
self: mugshot-debuginfo - 1.1.16-1.i386
Comment 1 Jeremy Katz 2006-10-15 20:13:38 EDT

*** This bug has been marked as a duplicate of 210630 ***

Note You need to log in before you can comment on or make changes to this bug.