Bug 210734 - mirror path get a double /
mirror path get a double /
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-13 18:51 EDT by Darwin H. Webb
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-19 10:46:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darwin H. Webb 2006-10-13 18:51:41 EDT
Description of problem:
site//dir on path
Tried many formats, even quoted strings and ../ /.. but it only get more confused.

fedora.cat.pdx.edu
linux/development/i386/os
becomes
http://fedora.cat.pdx.edu//linux/development/i386/os
this occured on OCT 12th and 13th
Version-Release number of selected component (if applicable):
anaconda-11.1.1.2-1 13th
anaconda-11.1.1.1-1 12th

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
tried http, ftp
Comment 1 Chris Lumens 2006-10-16 13:02:30 EDT
Please attach your /tmp/anaconda.log or a portion of your web server logs so I
see which fetches are having this problem.  There's a whole lot of code dealing
with slashes in the loader.
Comment 2 Darwin H. Webb 2006-10-16 19:21:46 EDT
It was an online install using the boot.iso.
It did not get pass the
site.mirror.edu
linux/development/i386/os
 screen so there was no anaconda stage2 or any log. It wouldn't even known which
/tmp to use at that point. It didn't even have a fs mounted.

Anaconda has not been updated since then. 

Darwin
Comment 3 Chris Lumens 2006-10-18 15:57:22 EDT
The bug here is that it's failing to download the second stage image from an
HTTP site?  Exactly what error message are you seeing on the screen?
Comment 4 Darwin H. Webb 2006-10-19 06:51:32 EDT
fedora.cat.pdx.edu
linux/development/i386/os
becomes
http://fedora.cat.pdx.edu//linux/development/i386/os


I think that says exactly what the problem was.
Thye error message was not found due to the double slash in the path.

But you close this as the OCT 18th http install worked without a problem.

thank you,

Darwin
Comment 5 Chris Lumens 2006-10-19 10:46:27 EDT
I've also made some fixes to the output to reflect what we are really trying to
fetch, as the printing code and the fetching code were using slightly different
strings.  We haven't rebuilt with that yet, but it will make it out eventually.
 Feel free to reopen this bug if you see this problem again in the future.

Note You need to log in before you can comment on or make changes to this bug.