Bug 210760 - Wrong colours if desktop effects are enabled
Wrong colours if desktop effects are enabled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
: EasyFix, Patch
: 212514 215667 216297 (view as bug list)
Depends On:
Blocks: 215786
  Show dependency treegraph
 
Reported: 2006-10-14 08:38 EDT by Torsten Rausche
Modified: 2009-06-27 11:42 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 05:41:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A screenshot (592.19 KB, image/png)
2006-10-14 08:38 EDT, Torsten Rausche
no flags Details
Xorg log (37.65 KB, text/plain)
2006-10-14 08:40 EDT, Torsten Rausche
no flags Details
Updated tfp-damage patch (5.94 KB, patch)
2006-11-14 22:01 EST, Frank Arnold
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 8095 None None None Never

  None (edit)
Description Torsten Rausche 2006-10-14 08:38:46 EDT
Description of problem:
On my last generation Apple iBook G4 I get my screen coloured in crazy hues when
I enable desktop effects. Though the effects are working.
Other 3D applications are not affected. Look at glxgears on the screenshot.
I am not sure if this is caused by compiz or another component.

Version-Release number of selected component (if applicable):
compiz.ppc           0.0.13-0.32.20060817git.fc6
xorg-x11-drv-ati.ppc 6.6.2-4.fc6
mesa.ppc             6.5.1-7.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Enable desktop effects.
  
Actual results:
Strange colours.

Expected results:
Normal colours.

Additional info:
Screenshot and Xorg.0.log attached.
Comment 1 Torsten Rausche 2006-10-14 08:38:46 EDT
Created attachment 138501 [details]
A screenshot
Comment 2 Torsten Rausche 2006-10-14 08:40:30 EDT
Created attachment 138502 [details]
Xorg log
Comment 3 Haïkel Guémar 2006-10-26 19:18:48 EDT
It seems there's a patch to fix this bug, maybe it's worth to take a look at
https://bugs.freedesktop.org/show_bug.cgi?id=8095
http://librarian.launchpad.net/4923564/fix_glXDRIbindTexImage_for_32bpp_on_big_endian.patch
Comment 5 Heath Petty 2006-11-14 10:18:05 EST
I see the same think on my 12" G3 Ibook. I am going to try and test the patch
here soon.

-Heath
Comment 6 Frank Arnold 2006-11-14 19:27:16 EST
(In reply to comment #5)
> I see the same think on my 12" G3 Ibook. I am going to try and test the patch
> here soon.

This patch doesn't apply to the current xorg-x11-server packages in Rawhide and
FC6. Perhaps we'll have to wait until Xorg 7.2 hits the streets.

Reassigning to xorg-x11-server. Correct me, if I'm wrong.
Comment 7 Frank Arnold 2006-11-14 22:01:23 EST
Created attachment 141208 [details]
Updated tfp-damage patch

Silly me, should have looked at the already applied patches. I've built a
package with the updated tfp-damage patch, and it works for me.
Comment 8 Frank Arnold 2006-11-15 01:22:20 EST
*** Bug 215667 has been marked as a duplicate of this bug. ***
Comment 9 Frank Arnold 2006-11-15 01:23:51 EST
*** Bug 212514 has been marked as a duplicate of this bug. ***
Comment 10 Jarod Wilson 2006-11-15 10:34:13 EST
If the patch is applied as #110 to xorg-x11-server-1.1.1-47.fc6, it applies
cleanly, builds cleanly, and results in proper-working and proper-color eye-candy.
Comment 11 Adam Thompson 2006-11-15 13:29:48 EST
I don't understand why we need such an extensive patch (#8) if it's just an
endinanness problem that is fixed by a 4-line patch?

(http://gitweb.freedesktop.org/?p=xorg/xserver.git;a=blobdiff;h=170662c7ebf3a7ea8f3b2998165e869bd04d960f;hp=b5723049dd573e2e3018fb9ba5a3008499b98350;hb=3ad1642f1bbaa5f96558cdf338;f=GL/glx/glxdri.c)

Are we fixing a different problem?
Comment 12 Jarod Wilson 2006-11-15 13:36:54 EST
Eep. The patch I'm referring to was the 4-line one, not the one in comment #8.
It works fine with the tfp-damage patch already in xorg-x11-server-1.1.1-47.fc6.

SRPM w/patch (as well as binary builds in the same dir):

http://wilsonet.com/packages/xorg-ppc-compiz-fix/xorg-x11-server-1.1.1-47.1.fc6.src.rpm

The patch I used is already attached to bug 215667:
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=141217
Comment 13 Frank Arnold 2006-11-15 14:21:47 EST
(In reply to comment #11)
> I don't understand why we need such an extensive patch (#8) if it's just an
> endinanness problem that is fixed by a 4-line patch?

Calm down people...

The original tfp-damage patch as found in xorg-x11-server-1.1.1-47.fc6
introduces the code where the 4-line patch matches. I just combined both patches.

The only thing that needs to be done is replacing the
xorg-x11-server-1.1.0-tfp-damage.patch with the one in comment #7 (which
incorporates the 4-liner), bumping the version, and adding a Changelog entry.
The result is the same, but cleaner from packagers perspective... ;)
Comment 14 Jarod Wilson 2007-01-11 22:41:42 EST
Any reason this patch hasn't made it into an FC6 build yet?
Comment 15 Frank Arnold 2007-02-27 03:34:25 EST
Fixed in Rawhide, but still no changes for FC6. Setting version to FC6 accordingly.
Comment 16 Adam Jackson 2007-03-27 11:23:14 EDT
*** Bug 216297 has been marked as a duplicate of this bug. ***
Comment 17 Matěj Cepl 2007-12-10 04:22:57 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]

Note You need to log in before you can comment on or make changes to this bug.