Bug 210764 - [packaging bug] configuration/org.eclipse.update/platform.xml has references to fetures to all SDK features
[packaging bug] configuration/org.eclipse.update/platform.xml has references ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
: 212559 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-14 10:11 EDT by Brian G. Anderson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.2.1-24.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-06 15:08:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of error message (222.61 KB, image/jpeg)
2006-10-14 10:11 EDT, Brian G. Anderson
no flags Details
Screenshot of error message (501.35 KB, image/png)
2006-10-15 01:36 EDT, Brian G. Anderson
no flags Details
part of workspace/.metadata/.log with stack trace (6.40 KB, text/plain)
2006-10-15 02:01 EDT, Brian G. Anderson
no flags Details

  None (edit)
Description Brian G. Anderson 2006-10-14 10:11:20 EDT
Description of problem:
I did a fresh install of eclipse and tried to do help->software updates->find
and install and I got the error dialog shown in the screen shot attachement.  It
lets me proceed and I try and add some additional modules from the calisto site,
but then I get the same error when I select any module and it doesn't let me
continue


Version-Release number of selected component (if applicable):
eclipse-platform-3.2.1-4.fc6
eclipse-jdt-3.2.1-4.fc6
eclipse-rcp-3.2.1-4.fc6
eclipse-ecj-3.2.1-4.fc6


How reproducible:
always after a fresh install of eclipse

Steps to Reproduce:
1.install eclipse
2.try and add a new module using help->software udpates->find and install
3.
  
Actual results:
error message about file not found


Expected results:
no error message.

Additional info:
I started eclipse as root and the selected help->software updates->find and
install.  I then exited eclipse and restart as a normal user.  This cleared the
problem and now I can add modules as a normal user
Comment 1 Brian G. Anderson 2006-10-14 10:11:21 EDT
Created attachment 138507 [details]
Screenshot of error message
Comment 2 Ben Konrath 2006-10-14 12:41:00 EDT
(In reply to comment #1)
> Created an attachment (id=138507) [edit]
> Screenshot of error message

Hmm, this isn't a screenshot of the error message. Could you please attach your
workspace/.metadata/.log file?
Comment 3 Ben Konrath 2006-10-14 12:47:34 EDT
(In reply to comment #0)
> I started eclipse as root and the selected help->software updates->find and
> install.  I then exited eclipse and restart as a normal user.  This cleared the
> problem and now I can add modules as a normal user

You shouldn't run eclipse as root because it writes configuration data in
/usr/share/eclipse/configuration. This locks eclipse into set configuration
because non-root users can't write to /usr/share/eclipse/configuration. It is
for this reason running eclipse as root is unsupported.
Comment 4 Brian G. Anderson 2006-10-15 01:36:07 EDT
Created attachment 138520 [details]
Screenshot of error message
Comment 5 Brian G. Anderson 2006-10-15 01:49:38 EDT
I've corrected the screenshot (sorry too quick with the file selection)

Also, yes I know that one isn't supposed to run eclipse as root, but by doing so
I was able to work around the bug.  Without doing this I could find no way to
add additional modules to eclipse.
Comment 6 Brian G. Anderson 2006-10-15 02:01:26 EDT
Created attachment 138521 [details]
part of workspace/.metadata/.log with stack trace
Comment 7 Ben Konrath 2006-10-16 00:21:11 EDT
(In reply to comment #5)
> I've corrected the screenshot (sorry too quick with the file selection)
> 
> Also, yes I know that one isn't supposed to run eclipse as root, but by doing so
> I was able to work around the bug.  Without doing this I could find no way to
> add additional modules to eclipse.

Understandable. 

I think I know what's going on here: Extracting the shared libraries after the
build is complete has the side-effect of creating a default configuration. This
configuration has references to all features that were installed when the shared
libraries were extracted, namely all the features in the SDK. In this case there
is a reference to
org.eclipse.platform.source_3.2.1.r321_v20060921-MGDh_08KUYM-Bvn/feature.xml in
/usr/share/eclipse/configuration/org.eclipse.update/platform.xml. When you run
Eclipse as root, it is able to write to /usr/share/eclipse/configuration so it
can correct the mis-configuration of
/usr/share/eclipse/configuration/org.eclipse.update/platform.xml. 

We are planning to get rid of this default configuration in the next update of
Eclipse. Since /usr/share/eclipse/configuration is not writable as a user and
there is no default configuration in /usr/share/eclipse/configure, one would be
created in ~/.eclipse/configuration and this problem would go away. 

Thanks for the bug report.
Comment 8 Ben Konrath 2006-10-27 12:54:32 EDT
*** Bug 212559 has been marked as a duplicate of this bug. ***
Comment 9 Ben Konrath 2007-02-06 15:08:46 EST
This should be fixed in 3.2.1-24.fc6. Since you ran eclipse as root, you may
have to uninstall eclipse, sudo rm -r /usr/share/eclipse and reinstall eclipse.
If you are still having problems, feel free to re-open this bug.

Note You need to log in before you can comment on or make changes to this bug.