Bug 210770 - Selinux policy stops Squid for using the diskd storage format.
Summary: Selinux policy stops Squid for using the diskd storage format.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-14 16:51 UTC by Daniel Rowe
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 20:04:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Rowe 2006-10-14 16:51:30 UTC
Description of problem:

Selinux policy stops Squid for using the diskd non-blocking storage format.

Version-Release number of selected component (if applicable):

squid-2.5.STABLE14-2.FC5
libselinux-1.30.3-4.fc5
selinux-policy-targeted-2.3.7-2.fc5
libselinux-python-1.30.3-4.fc5
selinux-policy-2.3.7-2.fc5

How reproducible:

Everytime

Steps to Reproduce:

1. Add diskd storage format to squid.conf.
2. Restart Squid.
  
Actual results:

Squid fails to restart due to selinux policy.

Expected results:

Squid to run normally with diskd storage format.

Additional info:

audit(1160843644.324:5): avc:  denied  { read write } for  pid=4936 comm="squid"
name="SYSV004d2002" dev=tmpfs ino=1114131 scontext=user_u:system_r:squid_t:s0
tcontext=user_u:object_r:tmpfs_t:s0 tclass=file
audit(1160843647.609:6): avc:  denied  { read write } for  pid=4943 comm="squid"
name="SYSV004d3c02" dev=tmpfs ino=1146900 scontext=user_u:system_r:squid_t:s0
tcontext=user_u:object_r:tmpfs_t:s0 tclass=file
audit(1160843650.893:7): avc:  denied  { read write } for  pid=4949 comm="squid"
name="SYSV004d5402" dev=tmpfs ino=1179669 scontext=user_u:system_r:squid_t:s0
tcontext=user_u:object_r:tmpfs_t:s0 tclass=file
audit(1160843654.177:8): avc:  denied  { read write } for  pid=4956 comm="squid"
name="SYSV004d7002" dev=tmpfs ino=1212438 scontext=user_u:system_r:squid_t:s0
tcontext=user_u:object_r:tmpfs_t:s0 tclass=file
audit(1160843657.533:9): avc:  denied  { read write } for  pid=4995 comm="squid"
name="SYSV004e0c02" dev=tmpfs ino=1277976 scontext=user_u:system_r:squid_t:s0
tcontext=user_u:object_r:tmpfs_t:s0 tclass=file

Comment 1 Daniel Walsh 2006-10-16 17:51:18 UTC
Fixed in selinux-policy-2.3.7-4.fc5

Comment 2 Daniel Walsh 2007-03-28 20:04:33 UTC
Closing bugs



Note You need to log in before you can comment on or make changes to this bug.