Bug 210772 - leftover scim processes
Summary: leftover scim processes
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: scim-bridge   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: 211260
TreeView+ depends on / blocked
 
Reported: 2006-10-14 20:07 UTC by Matthias Clasen
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 00:31:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Clasen 2006-10-14 20:07:47 UTC
After logging out, I see a number of scim-related process hang around (maybe
they die eventually, I didn't wait longer than ~2 minutes):
scim-launcher, scim-bridge and scim-helper-manager

Comment 1 Jens Petersen 2006-10-18 07:57:01 UTC
I have seen this too sometimes in the past.
Do you have a systematic way to reproduce.
Was it after updating scim-bridge while running the desktop say?

Comment 2 Jens Petersen 2006-10-18 07:59:23 UTC
Also could you list the processes that are left running, please?

Comment 3 Matthias Clasen 2006-10-21 02:24:09 UTC
I see scim-launcher and scim-bridge being left behind

Comment 4 Jens Petersen 2006-10-23 07:57:38 UTC
Ok, the args to the scim-launcher process would be useful since there
are normally two running.

Do you see this after every desktop session?  I don't know how to reproduce
this yet.

Comment 5 Jens Petersen 2006-11-29 08:07:06 UTC
One way to induce the lingering processes is the following:

1. login to desktop
2. start app supporting IM
3. activate IM with Ctrl-Space
4. quit X with Ctrl-Alt-Backspace
5. run "ps aux | grep scim" in console

and one sees scim-bridge and the scim-launcher socket processes still running.
"killall -9 scim-bridge" cleans them away.

Comment 6 Jens Petersen 2006-11-29 08:08:36 UTC
I still see this with scim-bridge-0.4.8.
If scim-bridge is not installed there are no remaining scim processes.

Comment 7 Ryo Dairiki 2006-12-01 17:05:44 UTC
I've applied a patch on the CVS latest.
Now it must shutdown itself in a half minute.
It still struggles to launch the panel process, but finally shutdowns itself in
15 secs.

Comment 8 Jens Petersen 2007-01-02 00:31:49 UTC
Thank you!  Should be in scim-bridge-0.4.9-1.fc7.


Note You need to log in before you can comment on or make changes to this bug.