Bug 210778 - listen should "Require:" gstreamer-python, python-mutagen, gnome-python2-gtkmozembed
listen should "Require:" gstreamer-python, python-mutagen, gnome-python2-gtkm...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: listen (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Haïkel Guémar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-14 18:19 EDT by Moritz Barsnick
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-15 04:04:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 210176 None None None Never

  None (edit)
Description Moritz Barsnick 2006-10-14 18:19:08 EDT
Description of problem:
The listen RPM installs quietly without gstreamer-python, python-mutagen, gnome-
python2-gtkmozembed, but cannot run without these packages. These should be 
added to the "Requires:" line.

Requires: gstreamer-python python-mutagen gnome-python2-gtkmozembed

Version-Release number of selected component (if applicable):
listen-0.5-5.beta1.fc5

How reproducible:
always

Steps to Reproduce:

> rpm -q listen
listen-0.5-5.beta1.fc5
> listen
Traceback (most recent call last):
  File "/usr/lib/listen/listen.py", line 50, in ?
    import pygst
ImportError: No module named pygst
> su -c "rpm -ivh gstreamer-python-0.10.4-1.fc5.i386.rpm"
Preparing...                ########################################### [100%]
   1:gstreamer-python       ########################################### [100%]
> listen
Traceback (most recent call last):
  File "/usr/lib/listen/listen.py", line 209, in ?
    ListenApp()
  File "/usr/lib/listen/listen.py", line 136, in __init__
    from widget.listen import Listen
  File "/usr/lib/listen/widget/listen.py", line 33, in ?
    from player import Player
  File "/usr/lib/listen/player.py", line 32, in ?
    from song import sType
  File "/usr/lib/listen/song.py", line 50, in ?
    import formats.mutagen_tag
  File "/usr/lib/listen/formats/mutagen_tag.py", line 28, in ?
    import mutagen.apev2
ImportError: No module named mutagen.apev2
> su -c "rpm -ivh python-mutagen-1.6-2.fc5.noarch.rpm"
Preparing...                ########################################### [100%]
   1:python-mutagen         ########################################### [100%]
> listen
No musicbrainz2 support
No musicbrainz2 support
No Audio cd support
Traceback (most recent call last):
  File "/usr/lib/listen/listen.py", line 209, in ?
    ListenApp()
  File "/usr/lib/listen/listen.py", line 136, in __init__
    from widget.listen import Listen
  File "/usr/lib/listen/widget/listen.py", line 37, in ?
    from widget.source_ui import SourceUI
  File "/usr/lib/listen/widget/source_ui.py", line 39, in ?
    from source.info_source import *
  File "/usr/lib/listen/source/info_source.py", line 26, in ?
    from widget.webinfo import *
  File "/usr/lib/listen/widget/webinfo.py", line 53, in ?
    import widget.mozembed_wrap
  File "/usr/lib/listen/widget/mozembed_wrap.py", line 22, in ?
    import gtkmozembed
ImportError: No module named gtkmozembed
> su -c "rpm -ivh gnome-python2-gtkmozembed-2.14.0-3.fc5.i386.rpm"
Preparing...                ########################################### [100%]
   1:gnome-python2-gtkmozemb########################################### [100%]
> listen
No musicbrainz2 support
No musicbrainz2 support
No Audio cd support
No Notify support

Additional info:
The final four error messages are due to other missing gstreamer libs, but they 
are optional, i.e. the program actually runs without these.

This bug report is an extension of bug #210176.

Thanks for packaging this tool!
Comment 1 Haïkel Guémar 2006-10-15 04:04:27 EDT
fixed by release listen-0.5.beta1-6 and listen-0.5.beta1-7 should be soon on
repositories.
$ rpm -qa | grep "listen"
listen-0.5-6.beta1.fc5
$ rpm -q --whatrequires gstreamer-python
listen-0.5-6.beta1.fc5
$ rpm -q --whatrequires python-mutagen
listen-0.5-6.beta1.fc5
$ rpm -q --whatrequires gnome-python2-gtkmozembed
listen-0.5-6.beta1.fc5

known bug: missing Requires:gnome-python2-gtkhtml2 (corrected in
listen-0.5-7.beta1 , just a matter of time before it will be uploaded on mirrors)

Here are the requires of the last release:
Requires: python-mutagen >= 1.6
Requires: python 
Requires: pygtk2 
Requires: gstreamer-python 
Requires: dbus-python
Requires: python-sqlite2
Requires: python-ctypes
Requires: gnome-python2
Requires: gnome-python2-extras
Requires: gnome-python2-gtkmozembed
Requires: gnome-python2-gtkhtml2
Requires: gnome-python2-libegg
Requires: python-sexy
# MusicBrainz support
Requires: python-musicbrainz2 
Requires: /usr/bin/puid    

It also fix a broken dependency in fc6 with libtunepimp.


Anyway, thanks, if you find any other missing requires, feel free to report them.

Note You need to log in before you can comment on or make changes to this bug.