Bug 210780 - Network manager not connecting to wireless networks it can see
Network manager not connecting to wireless networks it can see
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-14 18:35 EDT by darrell pfeifer
Modified: 2008-04-03 17:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 17:26:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description darrell pfeifer 2006-10-14 18:35:59 EDT
Description of problem:

At system boot there is a timing problem where ipw2200 wireless firmware
sometimes fails to load in time. The driver emits a message that says it is
delaying initialization. This results in the device being given a 'fake' device
name rather than (in my case) eth1.

In versions of network manager up to about fc6 test 2 network manager would find
the 'fake' device ID and the network would function properly.

Recent versions of network manager don't seem to handle this situation well. Now
it is able to talk to the wireless card (it can see various networks) but will
not connect to any of them.

As a workaround I am able to rmmod ipw2200 and then insmod it again. This allows
eth1 to be created and work, although network manager still refuses to connect
to anything.

Note that I have 3 laptops, one with ipw2200, one with ipw2100 and another with
a hermes card. All are running a completely updated rawhide and all three have
very unstable (that is, can't connect to wireless ap's that can be seen) network
managers.

(Aside... I don't know if this has any relevance, but all three systems
encountered the problem with the hal (dbus?) rpm post install scriptlet failing
due to a typo)

Oct 14 15:27:40 localhost NetworkManager: <WARNING>     
nm_device_802_11_wireless_get_mode (): error getting card mode on
__tmp1804289383: No such device 
Oct 14 15:27:40 localhost NetworkManager: <WARNING>     
nm_device_802_11_wireless_scan (): could not trigger wireless scan on device
__tmp1804289383: No such device 
Oct 14 15:27:40 localhost NetworkManager: <WARNING>     
nm_device_802_11_wireless_get_mode (): error getting card mode on
__tmp1804289383: No such device 
Oct 14 15:28:48 localhost java: gethostby*.getanswer: asked for "www.gay.com IN
AAAA", got type "A"
Oct 14 15:29:54 localhost NetworkManager: <WARNING>     
nm_device_802_11_wireless_get_mode (): error getting card mode on
__tmp1804289383: No such device 
Oct 14 15:29:54 localhost NetworkManager: <WARNING>     
nm_device_802_11_wireless_get_mode (): error getting card mode on
__tmp1804289383: No such device 
Oct 14 15:29:54 localhost NetworkManager: <WARNING>     
nm_device_802_11_wireless_scan (): could not trigger wireless scan on device
__tmp1804289383: No such device 
Oct 14 15:29:54 localhost NetworkManager: <WARNING>     
nm_device_802_11_wireless_get_mode (): error getting card mode on
__tmp1804289383: No such device 

[darrell@localhost gspcav1-20060925]$ ls -l /var/run
total 224
srw-rw-rw- 1 root  root      0 Oct 14 08:15 acpid.socket
-rw-r--r-- 1 root  root      5 Oct 14 08:16 atd.pid
-rw-r--r-- 1 root  root      5 Oct 14 08:15 auditd.pid
srwxr-xr-x 1 root  root      0 Oct 14 08:15 audit_events
drwxr-xr-x 2 avahi avahi  4096 Oct 14 08:16 avahi-daemon
drwxr-xr-x 2 root  root   4096 Oct 14 08:16 console
-rw-r--r-- 1 root  root      5 Oct 14 08:16 crond.pid
drwxr-xr-x 3 root  lp     4096 Oct  5 08:43 cups
-rw-r--r-- 1 root  root      5 Oct 14 08:15 cupsd.pid
drwxr-xr-x 2 root  root   4096 Oct 14 08:15 dbus
---------- 1 root  root      4 Oct 14 08:16 dhcdbd.pid
-rw-r--r-- 1 root  root      5 Oct 14 08:18 dhclient-eth1.pid
-rw-r--r-- 1 root  root      5 Oct 14 08:17 dhclient-__tmp1804289383.pid
Comment 1 Bug Zapper 2008-04-03 14:30:28 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 2 darrell pfeifer 2008-04-03 17:26:41 EDT
Yes, this has definitely gone stale. Not a problem in current rawhide. Closing.

Note You need to log in before you can comment on or make changes to this bug.