Bug 210782 - [Patch] Activation of URLs in About Dialog
[Patch] Activation of URLs in About Dialog
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hugh Brock
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-14 19:05 EDT by Damien Durand
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-17 08:53:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
FixURLAboutDialog (681.42 KB, application/octet-stream)
2006-10-14 19:05 EDT, Damien Durand
no flags Details

  None (edit)
Description Damien Durand 2006-10-14 19:05:32 EDT
Hi,

I submit a small patch for activated URLs in About Dialog. User can click on the
website label or mail adress and a web browser or mail application is
automatically open. See this screenshot for more details :
http://glive.tuxfamily.org/blog/images/AboutDialog.png

Regars,

Damien
Comment 1 Damien Durand 2006-10-14 19:05:35 EDT
Created attachment 138519 [details]
FixURLAboutDialog
Comment 2 Daniel Berrange 2006-10-17 13:48:46 EDT
The python code part of the patch looks reasonable. Unfortunately whatever glade
changes were made are practically unidentifiable because Glade-3 has totally
mangled the original glade file.  Could you let me know what changes were needed
in the glade UI, so I can make sure they get incorporated correctly. 

Aside from that, looks like a good & straightforward feature to incorporate.
Comment 3 Damien Durand 2006-10-22 08:35:42 EDT
In vmm-about add http://virt-manager.et.redhat.com/ in the "WebSite label:" field.
Comment 4 Daniel Berrange 2006-11-06 11:46:36 EST
Incorported the patch upstream:

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=22889cdd3c60

Will push to a future FC6 errata
Comment 5 Fedora Update System 2006-11-10 09:45:38 EST
virt-manager-0.2.6-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 Fedora Update System 2006-11-17 08:28:25 EST
virt-manager-0.2.6-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.