Bug 210791 - FutureFeature - Add option to update existing grub.conf when installing on new partition
FutureFeature - Add option to update existing grub.conf when installing on ne...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-14 23:06 EDT by Dave
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-15 20:31:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave 2006-10-14 23:06:11 EDT
FutureFeature

Description of problem:
I usually have grub already set up in a boot partition before installing a new
Linux (I have other versions I'm happy with). I'd like to keep my existing
grub.conf, but add the new installation choice into the existing grub.conf and
not change mbr, etc. I always have to work around the installation choices to
get it to work, and it's not real easy. If anaconda would allow "update existing
grub", it would make adding Linux much easier.

Version-Release number of selected component (if applicable):
All

How reproducible:
Always reproducable.

Steps to Reproduce:
1. Install Fedora into a new partition, when another Linux/grub exists.
2. Update previously existing /boot/grub/grub.conf with new install info.
  
Actual results:
Have to "don't install boot loader", mount new partition from existing /boot
partition, then figure out and type boot & root lines into existing
/boot/grub/grub.conf.

Expected results:
Prompt for "update existing grub.conf for new installation" during install.

Additional info:
Comment 1 Jeremy Katz 2006-10-15 20:31:31 EDT
The problem is that different distros do some different things regarding grub
set up.  And also, unless you use the same boot, things can be "interesting".

There's already the option to install grub to the boot partition, which is what
you want in this case and then you can set up your other grub to chain load the
Fedora partition.

Note You need to log in before you can comment on or make changes to this bug.