Bug 210794 - TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType' object has no attribute 'add_option'
TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType' object h...
Status: CLOSED DUPLICATE of bug 191630
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2006-10-15 02:06 EDT by Y. Ming
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-17 08:39:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Y. Ming 2006-10-15 02:06:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.4 (like Gecko)

Description of problem:
The software updater responded with an unhandled exception, and requested me 
to report a bug. The crash dump is given as below:

Component: Software Updater
Summary: TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType' 
object has no attribute 'add_option'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 382, in ?
  File "/usr/sbin/pup", line 377, in main
    pup = PackageUpdater()
  File "/usr/sbin/pup", line 77, in __init__
    GraphicalYumBase.__init__(self, False)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 123, in 
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 173, in 
    optparser, types)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 148, in 
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 164, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/downloadonly.py", line 26, in config_hook
    parser.add_option('', '--downloadonly', dest='dlonly', 
AttributeError: 'NoneType' object has no attribute 'add_option'

Local variables in innermost frame:
conduit: <yum.plugins.ConfigPluginConduit instance at 0xb792d26c>
parser: None

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Fedora>System>Software Updater.
2. Root Login

Actual Results:
Crash. Crash dump shown. Software terminates. 

Expected Results:
A GUI of software updates.

Additional info:
kernel 2.6.17-1.2187_FC5
Comment 1 Jeremy Katz 2006-10-17 08:39:56 EDT

*** This bug has been marked as a duplicate of 191630 ***

Note You need to log in before you can comment on or make changes to this bug.