Bug 210849 - rtorrent - FC5 - memory leaks?
rtorrent - FC5 - memory leaks?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rtorrent (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Chabot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-16 02:32 EDT by Chris Chabot
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.6.4-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 05:40:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Chabot 2006-10-16 02:32:40 EDT
On Sun, 2006-10-15 at 23:37 +0200, Lars Gullik Bjønnes wrote:
After the last update rtorrent/libtorrent is not behaving nicely.
> I am continously seeding the fedora 6 torrents (pre now), but after
> upgrading to rtorrent-0.6.2-3.fc5 libtorrent-0.10.2-2.fc5 I see
> massive memory leaks, so severe that after rtorrent has checked the
> hash for one torrent it quickly stops doing anything since it is
> unable to allocate/memorymap more memory.
> 
> USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
> larsbj    15   0 3380m 326m 317m S  0.7 32.7   4:33.24 rtorrent
> 
> This is on a box with 1GB RAM, x86_64.
> 
> Storage error: [File chunk write error: Cannot allocate memory.]
> 
> -- 
> 	Lgb
>
Comment 1 Lars Gullik Bjønnes 2006-10-25 06:20:09 EDT
I still se this, and it makes impossible to use rtorrent for downloading the fc6
torrents f.ex.

This is on a fairly updated fc5, only the latest kernel updates are missing.
Comment 2 Lars Gullik Bjønnes 2006-10-26 06:03:41 EDT
The problem is fixed by compiling with -O3 instead of -O2.

This is according to what the rtorrent web pages say about gcc 4.1.1 and
compile failures there.
Comment 3 Chris Chabot 2006-11-28 05:40:31 EST
Should be fixed with the 0.6.4-2 release.

rpm's are already available for develop & fc6, i'll push fc5 packages later this
week.

Note You need to log in before you can comment on or make changes to this bug.