Bug 210850 - querying ethX with ethtool does not show status information
querying ethX with ethtool does not show status information
Status: CLOSED DUPLICATE of bug 213325
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ethtool (Show other bugs)
5.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-16 03:50 EDT by ilja lunev
Modified: 2013-07-02 22:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 13:48:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ilja lunev 2006-10-16 03:50:39 EDT
Description of problem:
We have installed  "release 4.91 (Tikanga)" on some test machines and all
exhibit the same effect that ethtool does not show the complete status
information as it was with release 4 (Nahant).
Thus it is not possible to verify the actual settings e.g. for speed and duplex 


Version-Release number of selected component (if applicable):
Version     : 3                          
Release     : 1.2.2  

How reproducible:
 always


Steps to Reproduce:
1. ethtool eth0
  
Actual results:
 with release 4.91 (Tikanga) 
 > ethtool eth0
 Settings for eth0:
         Link detected: yes


Expected results:

as with release 4 (Nahant Update 4)
> ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 24
        Transceiver: internal
        Auto-negotiation: on
        Current message level: 0x00000001 (1)
        Link detected: yes


Additional info:
Network adapter information:
 Intel Corporation 82557/8/9 [Ethernet Pro 100]
or
 3Com Corporation 3c905C-TX/TX-M [Tornado]
Comment 1 ilja lunev 2006-10-31 02:56:39 EST
I discovered that the bug only applies to machines running the xen kernel
 2.6.17-1.2519.4.21.el5xen i686 'Red Hat Enterprise Linux Client release 4.91
(Tikanga)'

On a machine running el5 without xen kernel ethtool reports the status correctly
 2.6.17-1.2519.4.21.el5 'Red Hat Enterprise Linux Client release 4.91 (Tikanga)'
Comment 2 Bill Nottingham 2006-11-22 13:48:15 EST

*** This bug has been marked as a duplicate of 213325 ***

Note You need to log in before you can comment on or make changes to this bug.