Bug 210873 - kannel 1.4.0 (bearerbox) segfaults on startup on x86_64
kannel 1.4.0 (bearerbox) segfaults on startup on x86_64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kannel (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-16 09:40 EDT by Francois Aucamp
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.4.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-17 09:04:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francois Aucamp 2006-10-16 09:40:38 EDT
Description of problem:
When starting the bearerbox in kannel on FC5, x86_64, it immediately crashes
with a segmentation fault. It does not matter if it is started with or without a
configuration file. 

I should probably note that the config file I use works fine on FC5, i386 using
the same hardware and rpm version (GSM modem connected to serial port).


Version-Release number of selected component (if applicable):
# rpm -q kannel
kannel-1.4.0-8.fc5

How reproducible:
Always happens.

Steps to Reproduce:
1. Create kannel config file (default one is fine)
2. Start up the bearerbox with the config file, e.g. bearerbox -v 0 /etc/kannel.conf
  

Actual results:

Here is the output from the bearerbox command:

# bearerbox -v 0 /etc/kannel.conf

2006-10-16 15:21:44 [22229] [0] INFO: Debug_lvl = 0, log_file = <none>, log_lvl = 0
2006-10-16 15:21:44 [22229] [0] WARNING: DLR: using default 'internal' for
storage type.
2006-10-16 15:21:44 [22229] [0] INFO: DLR using storage type: internal
Segmentation fault


When starting bearerbox with a deliberately broken config file, I get the following:

# bearerbox -v 0 /etc/kannel.conf

2006-10-16 15:27:14 [22300] [0] INFO: Debug_lvl = 0, log_file = <none>, log_lvl = 0
2006-10-16 15:27:14 [22300] [0] ERROR: Group does not contain variable 'group'.
2006-10-16 15:27:14 [22300] [0] ERROR: Error found on line 25 of file
`/etc/kannel.conf'.
2006-10-16 15:27:14 [22300] [0] PANIC: Couldn't read configuration from
`/etc/kannel.conf'.
2006-10-16 15:27:14 [22300] [0] PANIC: bearerbox(gw_panic+0x193) [0x46ab63]
2006-10-16 15:27:14 [22300] [0] PANIC: bearerbox(main+0x968) [0x40c528]
2006-10-16 15:27:14 [22300] [0] PANIC: /lib64/libc.so.6(__libc_start_main+0xf4)
[0x36b191d084]
2006-10-16 15:27:14 [22300] [0] PANIC: bearerbox [0x40aec9]


Expected results:

This is the same config/hardware setup on an i386:
# bearerbox -v 0 /etc/kannel.conf

2006-10-16 15:33:51 [28631] [0] INFO: Debug_lvl = 0, log_file = <none>, log_lvl = 0
2006-10-16 15:33:51 [28631] [0] WARNING: DLR: using default 'internal' for
storage type.
2006-10-16 15:33:51 [28631] [0] INFO: DLR using storage type: internal
2006-10-16 15:33:51 [28631] [0] DEBUG: Kannel bearerbox version `1.4.0'.
Build `Mar  6 2006 12:00:01', compiler `4.1.0 20060304 (Red Hat 4.1.0-2)'.
System Linux, release 2.6.17-1.2157_FC5smp, version #1 SMP Tue Jul 11 23:24:16
EDT 2006, machine i686.
Hostname MobilEd, IP 127.0.0.1.
Libxml version 2.6.23.
Using OpenSSL 0.9.8a 11 Oct 2005.
Using SQLite 2.8.16.
Using native malloc.
.... 
etc (it runs fine from here)


Additional info:
This seems to be a known problem amongst the Kannel developers (just did a quick
google ;-) ); there are, however, some CVS RPM-workarounds floating around.
Refer to:
http://www.mail-archive.com/devel@kannel.org/msg06090.html
http://www.mail-archive.com/devel@kannel.org/msg06111.html
Comment 1 Matthias Saou 2006-10-16 09:46:13 EDT
Thanks for reminding me that I need to push the 1.4.1 update ;-)
Comment 2 Matthias Saou 2006-10-16 11:40:00 EDT
I've rebuilt 1.4.1 for FC5, making sure it's still the sqlite2 support that is
enabled in order to not break existing setups, since it's now sqlite3 that is
enabled for devel/FC6.

Expect the new builds to be available shortly, then please let me know if the
x86_64 package now works.
Comment 3 Francois Aucamp 2006-10-17 08:59:20 EDT
Thanks for the (extremely) quick response! :-)
I have just upgraded kannel via yum and it's now working fine under FC5, 
x86_64.
Thanks again, this bug is closed.

Note You need to log in before you can comment on or make changes to this bug.