Bug 210897 - gnome-screensaver hangs with dual-head setup
gnome-screensaver hangs with dual-head setup
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-screensaver (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-16 10:46 EDT by Jeff Needle
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 09:36:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 358963 None None None Never

  None (edit)
Description Jeff Needle 2006-10-16 10:46:02 EDT
Bug also present in RHEL5b1, so filing against that as well.

+++ This bug was initially created as a clone of Bug #210892 +++

Description of problem:
gnome-screensaver kicks in, blanks the screen, and one of the instances seems to
vanish.  Can't unlock screen except by killing the other instance of
gnome-screensaver.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.16.0-7.fc6

How reproducible:
100% in my configuration

Steps to Reproduce:
1.My xorg.conf is attached
2.Launch xscreensaver
3.
  
Actual results:
screen 0 blank, no dialogue box to unlock
screen 1 exposed, but panel non-responsive (as if locked)

Expected results:
both screens display screensaver, keystroke presents dialogue box

Additional info:
strace of remaining gnome-screensaver process looks like this (fragment -
continues on)

# strace -p2478
Process 2478 attached - interrupt to quit
restart_syscall(<... resuming interrupted call ...>) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 200000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 150000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 200000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 200000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 200000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 150000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 200000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 200000000},  <unfinished ...>

-- Additional comment from jneedle@redhat.com on 2006-10-16 10:37 EST --
Created an attachment (id=138579)
xorg.conf


-- Additional comment from mccann@jhu.edu on 2006-10-16 10:43 EST --
Looks like you are using Clone mode so it is probably this:
http://bugzilla.gnome.org/show_bug.cgi?id=354663
Comment 2 RHEL Product and Program Management 2006-10-16 11:32:46 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 4 Jeff Needle 2006-10-16 13:43:25 EDT
This issue was fixed upstream in gnome-screensaver-2.16.1.  I have tested it and
can verify that.
Comment 5 Ray Strode [halfline] 2006-10-16 14:00:26 EDT
great, moving to VERIFIED
Comment 7 Jay Turner 2006-11-13 09:36:02 EST
Closing out as included in latest RHEL5 builds (20061111.0)

Note You need to log in before you can comment on or make changes to this bug.