Bug 21095 - traceroute not working on rh7
traceroute not working on rh7
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: traceroute (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-19 15:48 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-20 13:38:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-19 15:48:28 EST
when runnung a tracroute I get :
traceroute to www.redhat.com (216.148.218.195), 30 hops max, 38 byte
packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

what is expect is :
[jorg] /home/jorg > /mnt/usr/sbin/traceroute www.redhat.com
traceroute to www.redhat.com (216.148.218.195), 30 hops max, 40 byte
packets
 1  tnt28.rtm1.nl.uu.net (213.116.1.28)  32.254 ms  33.621 ms  34.708 ms
 2  GE4-0.dr2.rtm1.nl.uu.net (212.153.209.2)  33.468 ms  34.811 ms  34.210
ms
 3  452.atm6-0.cr2.rtm1.nl.uu.net (212.136.177.109)  34.841 ms  32.311 ms 
34.719 ms
 4  152.atm1-0-0.xr1.ams2.alter.net (212.136.184.150)  35.575 ms  32.433
ms  41.205 ms
 5  SO-0-0-0.TR2.AMS2.Alter.Net (146.188.8.82)  35.466 ms  33.556 ms 
34.836 ms
 6  SO-6-0-0.TR2.LND2.Alter.Net (146.188.8.157)  40.339 ms  41.433 ms 
38.458 ms
 7  SO-6-0-0.IR2.NYC12.Alter.Net (146.188.15.54)  113.844 ms  110.570 ms 
110.946 ms
 8  so-1-0-0.IR2.NYC9.ALTER.NET (152.63.23.69)  111.733 ms  109.040 ms 
112.831 ms
 9  119.at-5-0-0.TR2.NYC9.ALTER.NET (152.63.1.202)  119.221 ms  110.705 ms 
109.551 ms
10  186.ATM6-0.XR2.NYC1.ALTER.NET (152.63.21.73)  112.146 ms  111.233 ms 
111.720 ms
11  194.ATM9-0-0.BR1.NYC1.ALTER.NET (146.188.177.157)  111.441 ms  109.672
ms  115.707 ms
12  atm9-0.nyc-bb8.cerf.net (134.24.32.49)  107.719 ms  113.810 ms  110.091
ms
ect ect 

the last traceroute is generated by the traceroute executable from a 
redhat 6.0. I am curently running rh7 upgraded from rh6.0 and
have installed all updated for rh7 (except emacs).
Comment 1 Tim Waugh 2000-11-20 08:21:50 EST
I have seen this on a multi-homed system.  Specifying -i eth1 didn't help, but
specifying -s <IP address of eth1> did.  Does that help in your case? (Use
ifconfig to find out the IP address of the interface you want to use, if it's
using DHCP.)
Comment 2 Need Real Name 2000-11-20 13:38:42 EST
Yes when is specify the ipaddress of the outgoing interface I indeed
get a correct traceroute. 
It is still strange that the orignal rh6.0 executable does not need
this extra hint and the new rh7 does!
My setups is a eth0 with 192.168.1.1 and a dailout ippp0 isdn ppp connection.
Comment 3 Need Real Name 2000-11-20 13:38:46 EST
Yes when is specify the ipaddress of the outgoing interface I indeed
get a correct traceroute. 
It is still strange that the orignal rh6.0 executable does not need
this extra hint and the new rh7 does!
My setups is a eth0 with 192.168.1.1 and a dailout ippp0 isdn ppp connection.
Comment 4 Jeff Johnson 2000-12-27 20:49:31 EST
This problem appears to be resolved.
Comment 5 Nils Philippsen 2001-01-24 05:52:27 EST
I wouldn't say that the problem is resolved. When traceroute fails to select
the correct outgoing interface automatically (which it did in the past), this
qualifies as a bug. That one couldn't work around it by specifying the outgoing
interface (instead you have to determine the IP address of your interface with
ifconfig because (thank you, IPv4!) your provider assigns a dynamic address to
you) is just one bug more.

I will try out the version from RawHide when I'm at home and have the time to
do it, but if that fails could we please reopen this bug?
Comment 6 D. Hugh Redelmeier 2002-08-09 17:08:52 EDT
This bug is surely the same as 17915.

Note You need to log in before you can comment on or make changes to this bug.