Bug 211003 - Xen version strings need to reflect exact Red Hat build number
Xen version strings need to reflect exact Red Hat build number
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-16 15:34 EDT by Stephen Tweedie
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-13 11:54:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Include RPM build version in the Xen startup version information (2.74 KB, patch)
2006-10-16 15:36 EDT, Stephen Tweedie
no flags Details | Diff
Updated version of the "xen-version-strings.patch" file (1.20 KB, patch)
2006-10-17 05:27 EDT, Stephen Tweedie
no flags Details | Diff

  None (edit)
Description Stephen Tweedie 2006-10-16 15:34:38 EDT
Description of problem:
The Xen version strings announced by the hypervisor at boot time are currently
too vague, giving no indication of the Red Hat build number.

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-1.2727.el5

How reproducible:
100%

Steps to Reproduce:
1. Boot.

Actual results:
Boot claims to be "xen-3.0-unstable"

Expected results:
"xen-3.0-unstable-1.2727.el5" or similar
Comment 1 Stephen Tweedie 2006-10-16 15:36:55 EDT
Created attachment 138614 [details]
Include RPM build version in the Xen startup version information
Comment 2 Don Zickus 2006-10-16 22:32:57 EDT
in kernel-2.6.18-1.2728.el5
Comment 3 Stephen Tweedie 2006-10-17 05:25:46 EDT
Not fixed --- the patch was mis-applied.  It creates the
"xen-version-strings.patch" file in kernel*/xen/, rather than *applying* it in
kernel*/xen.

Will attach new version of xen-version-strings.patch in a form that can be
dropped in, and which works against the new "rc5" version currently in CVS.
Comment 4 Stephen Tweedie 2006-10-17 05:27:15 EDT
Created attachment 138669 [details]
Updated version of the "xen-version-strings.patch" file

to be dropped directly into CVS.
Comment 5 Jay Turner 2007-02-13 11:54:18 EST
Patches confirmed in 2.6.18-8.el5.

Note You need to log in before you can comment on or make changes to this bug.