Bug 211040 - repoquery - AttributeError: YumAvailablePackageSqlite instance has no attribute 'returnEVR'
repoquery - AttributeError: YumAvailablePackageSqlite instance has no attribu...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-16 17:10 EDT by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.1-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-14 04:06:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2006-10-16 17:10:17 EDT
$ repoquery --whatrequires libgpgme.so.6
Excluding Packages from Fedora Core - Development
Finished
Traceback (most recent call last):
  File "/usr/bin/repoquery", line 690, in ?
    main(sys.argv)
  File "/usr/bin/repoquery", line 687, in main
    repoq.runQuery(regexs)
  File "/usr/bin/repoquery", line 405, in runQuery
    pkgs = self.matchPkgs(items)
  File "/usr/bin/repoquery", line 381, in matchPkgs
    exact, match, unmatch = yum.packages.parsePackages(self.returnPkgList(),
  File "/usr/bin/repoquery", line 337, in returnPkgList
    pkgs = self.pkgSack.returnNewestByNameArch()
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 287, in retur
nNewestByNameArch
    bestofeach.addList(self._computeAggregateListResult("returnNewestByNameArch"
, naTup))
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 323, in _comp
uteAggregateListResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 465, in return
NewestByNameArch
    return yumRepo.YumPackageSack.returnNewestByNameArch(self, naTup)
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 563, in retur
nNewestByNameArch
    if pkg.EVR > pkg2.EVR:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 330, in <lambda>
    EVR = property(fget=lambda self: self.returnEVR())
AttributeError: YumAvailablePackageSqlite instance has no attribute 'returnEVR'
Comment 1 Tim Lauridsen 2007-01-14 03:42:34 EST
I have tested with FC6 / yum 3.0.3 / yum-utils-1.0.1.

Looks like the error is fixed, please retest.
Comment 2 Michael Schwendt 2007-01-14 04:06:47 EST
Apparently.

Note You need to log in before you can comment on or make changes to this bug.